hdu 1520 Anniversary party(基本树形DP)

1、http://acm.hdu.edu.cn/showproblem.php?pid=1520

2、题目大意:

有n个员工,每个员工都有一个rating值,给出员工之间的上下级的关系,要求是有直接上下级关系的员工不能同时出席,现在要求的是选择哪些员工出席,会使得他们的rating之和最大

定义dp[i][1]表示i员工出席时的最大值,dp[i][0]表示i员工不出席时的最大值

dp[i][1]=dp[v][0]//当i员工出席时,就等于他的所有直接下属v不出席时的最大值

dp[i][0]=max(dp[v][1],dp[v][0])//当i员工不出席时,就等于他的下属出席或者不出席的最大值

3、题目:

Anniversary party

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3617    Accepted Submission(s): 1680


Problem Description
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.


 

Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0


 

Output
Output should contain the maximal sum of guests' ratings.


 

Sample Input
  
  
7 1 1 1 1 1 1 1 1 3 2 3 6 4 7 4 4 5 3 5 0 0


 

Sample Output
  
  
5


 

4、AC代码:

#include<stdio.h>
#include<vector>
using namespace std;
#define N 6005
vector<int> vec[N];
int rating[N];
int f[N];
int dp[N][2];//dp[i][1]表示i结点选择,dp[i][0]表示i结点不选择
void dfs(int root)
{
    dp[root][1]=rating[root];
    for(int i=0; i<vec[root].size(); i++)
    {
        int v=vec[root][i];
        dfs(v);
        dp[root][1]+=dp[v][0];
        dp[root][0]+=max(dp[v][1],dp[v][0]);
    }
}
int main()
{
    int n,l,k;
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&rating[i]);
            f[i]=-1;//标记根节点
            vec[i].clear();
            dp[i][0]=0;
            dp[i][1]=0;
        }
        while(scanf("%d%d",&l,&k)!=EOF)
        {
            if(l==0 && k==0)
                break;
            vec[k].push_back(l);
            f[l]=k;
        }
        int a=1;
        while(f[a]!=-1)
        {
            a=f[a];
        }
        dfs(a);
        printf("%d\n",max(dp[a][1],dp[a][0]));
    }
    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值