Time

Description

Digital clock use 4 digits to express time, each digit is described by 3*3 characters (including”|”,”_”and” “).now given the current time, please tell us how can it be expressed by the digital clock.
</br ></span style="line-height:normal;text-indent:27px;white-space:normal;font-family:'microsoft yahei';"></span style="line-height:normal;"></span style="font-family:'dejavu "></div style="text-indent:27px;">

Input

There are several test cases.
Each case contains 4 integers in a line, separated by space.
Proceed to the end of file.

Output

For each test case, output the time expressed by the digital clock such as Sample Output.

Sample Input

1 2 5 6
2 3 4 2

Sample Output

    _  _  _ 
  | _||_ |_ 
  ||_  _||_|
 _  _     _ 
 _| _||_| _|
|_  _|  ||_ 

Hint

The digits showed by the digital clock are as follows:
   _  _     _  _  _  _  _  _ 
 | _| _||_||_ |_   ||_||_|| |
 ||_  _|  | _||_|  ||_| _||_|
 
   
一开始看这个题我就蒙了,这是什么啊,后来想了好长时间才发现,其实可以讲=将那10个数字从上到下分成3部分,相同的在一起表示,不同的分别表示出来,但是要注意格式问题。
#include <iostream>
using namespace std;
int main()
{
    int a[4];
    while(cin>>a[0]>>a[1]>>a[2]>>a[3])
    {
        for(int j=1; j<=3; j++)
        {
            if(j==1)
            {
                for(int i=0; i<4; i++)
                {
                    if(a[i]==1||a[i]==4)
                        cout<<"   ";
                    else
                        cout<<" _ ";
                }
            }
            if(j==2)
            {
                for(int i=0; i<4; i++)
                {
                    if(a[i]==1||a[i]==7)
                        cout<<"  |";
                    else if(a[i]==0)
                        cout<<"| |";
                    else if(a[i]==2||a[i]==3)
                        cout<<" _|";
                    else if(a[i]==4||a[i]==8||a[i]==9)
                        cout<<"|_|";
                    else
                        cout<<"|_ ";
                }
            }
            if(j==3)
            {
                for(int i=0; i<4; i++)
                {
                    if(a[i]==0||a[i]==6||a[i]==8)
                        cout<<"|_|";
                    else if(a[i]==1||a[i]==4||a[i]==7)
                        cout<<"  |";
                    else if(a[i]==2)
                        cout<<"|_ ";
                    else
                        cout<<" _|";
                }
            }
            cout<<endl;
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值