hdu 1754 I Hate It(线段树,单点替换,求区间最值)

1、http://acm.hdu.edu.cn/showproblem.php?pid=1754

这道题目一直Runtime Error(STACK_OVERFLOW),原来是读入Q,U的时候不能只读入一个字符,得把回车也读进来

2、题目大意:

I Hate It

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 31258    Accepted Submission(s): 12409


Problem Description
很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
这让很多学生很反感。

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。


 

Input
本题目包含多组测试,请处理到文件结束。
在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。
学生ID编号分别从1编到N。
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。
接下来有M行。每一行有一个字符 C (只取'Q'或'U') ,和两个正整数A,B。
当C为'Q'的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。
当C为'U'的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。


 

Output
对于每一次询问操作,在一行里面输出最高成绩。


 

Sample Input
  
  
5 6 1 2 3 4 5 Q 1 5 U 3 6 Q 3 4 Q 4 5 U 2 9 Q 1 5


 

Sample Output
  
  
5 6 5 9
Hint
Huge input,the C function scanf() will work better than cin


 

Author
linle


 

Source


 

Recommend
lcy   |   We have carefully selected several similar problems for you:  1542 2795 1540 1255 1828

 

3、AC代码:

#include<stdio.h>
#include<algorithm>
using namespace std;
#define N 2222220
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
int ma[N*4];
void updateUp(int rt)
{
    ma[rt]=max(ma[rt<<1],ma[rt<<1|1]);
}
void build(int l,int r,int rt)
{
    if(l==r)
    {
        scanf("%d",&ma[rt]);
        return ;
    }
    int m=(l+r)>>1;
    build(lson);
    build(rson);
    updateUp(rt);
}
void update(int p,int v,int l,int r,int rt)
{
    if(l==r)
    {
        ma[rt]=v;
        return ;
    }
    int m=(l+r)>>1;
    if(p<=m)
        update(p,v,lson);
    else
        update(p,v,rson);
    updateUp(rt);
}
int query(int L,int R,int l,int r,int rt)
{
    if(L<=l && R>=r)
        return ma[rt];
    int m=(l+r)>>1;
//这样写错在if(L<=m)调用左孩子,直接返回,底下的if不执行
//    if(L<=m)
//        return query(L,R,lson);
//    if(R>m)
//        return query(L,R,rson);
    int ret=0;
    if(L<=m)
        ret=max(ret,query(L,R,lson));
    if(R>m)
        ret=max(ret,query(L,R,rson));
    return ret;
}
int main()
{
    int n,m,b,c;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        build(1,n,1);
        for(int i=1; i<=m; i++)
        {
            char x[2];//此处包含回车,不能直接用char x来读入
            scanf("%s%d%d",x,&b,&c);
            if(x[0]=='U')
            {
                update(b,c,1,n,1);
            }
            else if(x[0]=='Q')
            {
                printf("%d\n",query(b,c,1,n,1));
            }
        }
    }
    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值