poj 2352 Stars(简单树状数组)此题也可以用线段树来做

1、http://poj.org/problem?id=2352

2、题目大意:

给出n个点的坐标,定义一个点的等级为这个点的左下方的点的个数,输出等级为0的点的个数,等级为1的点的个数,一直输出到等级为n-1的点的个数

题目已经给出是按照y坐标排序的,y相同按照x从小到大排序的,所以可以直接用树状数组的三个必要函数求

用sum(x)求出这之前的个数,计算个数有多少个,输出即可

按照y升序给你n个星星的坐标,如果有m个星星的x,y坐标均小于等于星星A的坐标,那么星星A的等级为m。

分析:是一道树状数组题。举例来说,以下是题目的输入:

5

1 1

5 1

7 1

3 3

5 5

由于y坐标是升序的且坐标不重复,所以在星星A后面输入的星星的x,y坐标不可能都小于等于星星A。假如当前输入的星星为(3,3),易得我们只需要去找树状数组中小于等于3的值就可以了,即GetSum(3)。注意:A[i]表示x坐标为i的个数,C[]为A[]的树状数组,那么GetSum(i)就是序列中前i个元素的和,即x小于等于i的星星数。

本题还是一点要注意:星星坐标的输入可以是(0,0),所以我们把x坐标统一加1,然后用树状数组实现。

 

3、题目:

Stars
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 29351 Accepted: 12836

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

Source

4、AC代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define N 32005
int ans[32005];
int c[N];
int lowbit(int i)
{
    return i&(-i);
}
void update(int x,int v)
{
    //注意循环的最大值是N,也就是题目的最大值
    for(int i=x;i<=N;i+=lowbit(i))
    {
        c[i]+=v;
    }
}
int sum(int x)
{
    int tmp=0;
    for(int i=x;i>0;i-=lowbit(i))
    {
        tmp+=c[i];
    }
    return tmp;
}
int main()
{
    int n,x,y;
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&x,&y);
             //此处x,y是从0开始的,都后移一位
            x++;
            y++;
            int tmp=sum(x);
            ans[tmp]++;
            update(x,1);
        }
        for(int i=0;i<n;i++)
        {
            printf("%d\n",ans[i]);
        }
    }
    return 0;
}

附线段树代码:


 

#include <stdio.h>
#include <string.h>
#include <conio.h>
#define N 15000
#define M 32000
struct t
{
    int l;
    int r;
    int w;
} tree[M * 3];

void maketree(int s, int t, int n)
{
    tree[n].l = s;
    tree[n].r = t;
    tree[n].w = 0;
    if(t == s)
        return;
    int mid = (tree[n].l + tree[n].r) / 2;
    maketree(s, mid, n * 2);
    maketree(mid + 1, t, n * 2 + 1);
}
/*找在x坐标为t的星星的左下方有多少颗星星*/
int find(int s, int t, int n)
{
    if(tree[n].l == s && tree[n].r == t)
        return tree[n].w;
    else
    {
        int sum = 0;
        int mid = (tree[n].l + tree[n].r ) >> 1;
        if(s > mid )
            sum += find(s, t, n * 2 +1);
        else if(t <= mid)
            sum += find(s, t, n * 2);
        else
            sum += find(s, mid, n*2) + find(mid+1, t, n*2+1);
        return sum;
    }
}
/*更新线段树,一路上节点的w都增一*/
void insert(int x, int n)
{
    tree[n].w++;
    if(tree[n].l == tree[n].r && tree[n].r == x)
        return;
    int mid = (tree[n].l + tree[n].r ) >> 1;
    if(x <= mid)
        insert(x, n * 2);
    else insert(x, n * 2 + 1);
}

int main()
{
    int i;
    int n, max;
    int a[N], b, ans[M];

    freopen("in.txt", "r", stdin);
    scanf("%d", &n);
    max = 0;
    for(i=0; i<n; i++)
    {
        scanf("%d%d", &a[i], &b);
        max = max < a[i] ? a[i] : max;
    }
    maketree(0, max, 1);
    memset(ans, 0, sizeof(ans));
    for(i=0; i<n; i++)
    {
        ans[find(0, a[i], 1)]++;
        insert(a[i], 1);
    }
    for(i=0; i<n; i++)
    {
        printf("%d\n", ans[i]);
    }
    getch();
    return 0;
}


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
POJ 2182是一道使用树状数组解决的题目,题目要求对给定的n个数进行排序,并且输出每个数在排序后的相对位置。树状数组是一种用来高效处理前缀和问题的数据结构。 根据引用中的描述,我们可以通过遍历数组a,对于每个元素a[i],可以使用二分查找找到a到a[i-1]中小于a[i]的数的个数。这个个数就是它在排序后的相对位置。 代码中的query函数用来求前缀和,add函数用来更新树状数组。在主函数中,我们从后往前遍历数组a,通过二分查找找到每个元素在排序后的相对位置,并将结果存入ans数组中。 最后,我们按顺序输出ans数组的元素即可得到排序后的相对位置。 参考代码如下: ```C++ #include <iostream> #include <cstdio> using namespace std; int n, a += y; } } int main() { scanf("%d", &n); f = 1; for (int i = 2; i <= n; i++) { scanf("%d", &a[i]); f[i = i & -i; } for (int i = n; i >= 1; i--) { int l = 1, r = n; while (l <= r) { int mid = (l + r) / 2; int k = query(mid - 1); if (a[i > k) { l = mid + 1; } else if (a[i < k) { r = mid - 1; } else { while (b[mid]) { mid++; } ans[i = mid; b[mid = true; add(mid, -1); break; } } } for (int i = 1; i <= n; i++) { printf("%d\n", ans[i]); } return 0; } ``` 这段代码使用了树状数组来完成题目要求的排序功能,其中query函数用来求前缀和,add函数用来更新树状数组。在主函数中,我们从后往前遍历数组a,通过二分查找找到每个元素在排序后的相对位置,并将结果存入ans数组中。最后,我们按顺序输出ans数组的元素即可得到排序后的相对位置。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* *3* [poj2182Lost Cows——树状数组快速查找](https://blog.csdn.net/aodan5477/article/details/102045839)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 50%"] - *2* [poj_2182 线段树/树状数组](https://blog.csdn.net/weixin_34138139/article/details/86389799)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值