hdu 1686 Oulipo(简单KMP)只不过比赛的时候用了string.一直超时,改成char就一遍AC,纠结。。。

1、http://acm.hdu.edu.cn/showproblem.php?pid=1686

2、题目大意:

这道题目太纠结了,就是一道直接用KMP模板的题目,比赛的时候居然第一次想成做for循环次的KMP,超时了,后来知道只能用一次KMP了,结果用的string 一直超时,后来改成char居然一遍AC,还得好好熟悉算法

题目是给出两个字符串a,b,求a在b中出现多少次

3、题目:

Oulipo

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3999    Accepted Submission(s): 1578


Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

 

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.
 

Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

 

Sample Input
  
  
3 BAPC BAPC AZA AZAZAZA VERDI AVERDXIVYERDIAN
 

Sample Output
  
  
1 3 0
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1358  1711  3336  3746  2203

4、AC代码:
#include<stdio.h>
#include<iostream>
#include<string.h>
#include<string>
#include<algorithm>
using namespace std;
char s[1000005];
char a[10005];
char b[1000005];
int f[10005];
void getFail(char p[], int *f)
{
    int m=strlen(p);
    f[0]=f[1]=0;
    for(int i=1; i<m; ++i)
    {
        int j=f[i];
        while(j && p[i]!=p[j])j=f[j];
        f[i+1] = p[i]==p[j]?1+j:0;
    }
}
int find(char T[],char p[],int *f)
{
    getFail(p,f);
    int n=strlen(T);
    int m=strlen(p);
    int j=0;
    int sum=0;
    for(int i=0; i<n; ++i)
    {
        while(j && T[i]!=p[j])j=f[j];
        if(T[i]==p[j])++j;
        if(j==m)
        {
            sum++;
        }
    }
    return sum;
}
int main()
{
    int n;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%s",a);
        scanf("%s",b);
        int la=strlen(a);
        int lb=strlen(b);
        int sum=find(b,a,f);
        printf("%d\n",sum);
    }
    return 0;
}


附string 超时代码:

#include<iostream>
#include<string.h>
#include<string>
#include<algorithm>
using namespace std;
char s[1000005];
string a;
string b;
int f[10005];
void getFail(string p, int *f)
{
    int m=p.length();
    f[0]=f[1]=0;
    for(int i=1; i<m; ++i)
    {
        int j=f[i];
        while(j && p[i]!=p[j])j=f[j];
        f[i+1] = p[i]==p[j]?1+j:0;
    }
}
int find(string T,string p,int *f)
{
    getFail(p,f);
    int n=T.length();
    int m=p.length();
    int j=0;
    int sum=0;
    for(int i=0; i<n; ++i)
    {
        while(j && T[i]!=p[j])j=f[j];
        if(T[i]==p[j])++j;
        if(j==m)
        {
            sum++;
        }
    }
    return sum;
}
int main()
{
    int n;
    cin>>n;
    while(n--)
    {
       cin>>a;
        cin>>b;
        int la=a.length();
        int lb=b.length();
        int sum=find(b,a,f);
        //printf("%d\n",sum);
        cout<<sum<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值