Steps

1.题目:

 Steps
Time Limit: 3000MS Memory limit: 65536K
题目描述

 

One steps through integer points of the straight line. The length of a step must be nonnegative and can be by one bigger than, equal to, or by one smaller than the length of the previous step.

What is the minimum number of steps in order to get from x to y? The length of the first and the last step must be 1.
输入

Input consists of a line containing n, the number of test cases. For each test case, a line follows with two integers: 0<= x <= y < 231
输出

For each test case, print a line giving the minimum number of steps to get from xto y.
示例输入

3
45 48
45 49
45 50

示例输出

3
3
4


 

2.思路:题目叫简单,读懂题即可,题目是要求从x到y要走多少步,规则:

   1.首次、末次都是1,中间数只能比前一个数大一,或小一、或相等

3.代码:

#include<stdio.h>
int main()
{
    int n,x,y;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%d%d",&x,&y);
        int mid=(y-x)/2;
        int i=0,sum=0;
        while(1)
        {

            if(sum<=mid)
            {
                i++;
                sum+=i;
            }
            else
           {
               sum=sum-i;
               i=i-1;
                break;
           }
        }
        //printf("i=%d sum=%d\n",i,sum);
        //printf("%d %d\n",x,y);
        if(y-x-sum*2==0)
        i=i*2;
        else if((y-x-sum*2)<=i||(y-x-sum*2)==i+1)
        i=i*2+1;
        else
        i=(i+1)*2;
        printf("%d\n",i);
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值