hdu 1003 Max Sum(动态规划求一维最大子段和)

1、http://acm.hdu.edu.cn/showproblem.php?pid=1003

2、一维的求最大子段和问题

给定一串数字,求其中某段连续的数字和最大的那一段,输出最大子段的和以及这个字段的起始和结束位置

注意输出是两个样例之间有一个空行,不是每个样例后边都有空行

3、题目:

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 95836    Accepted Submission(s): 22142


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.


 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).


 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.


 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5


 

Sample Output
  
  
Case 1: 14 1 4 Case 2:

4、代码:

 

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[100005];
struct node
{
    int sum;
    int s;
    int e;
} dp[1000005];
int cmp(node a,node b)
{
    if(a.sum!=b.sum)
    return a.sum>b.sum;
    else
    return a.s<b.s;
}
int main()
{
    int t,n,cas=0;
    scanf("%d",&t);
    for(int cas=1;cas<=t;cas++)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        for(int i=1;i<=n;i++)
        {
            dp[i].sum=0;
            dp[i].e=i;
            dp[i].s=0;
        }
        dp[0].s=1;
        for(int i=1;i<=n;i++)
        {
            if(dp[i-1].sum>=0)
            {
                dp[i].sum=dp[i-1].sum+a[i];
                dp[i].s=dp[i-1].s;
                dp[i].e=i;
            }
            if(dp[i-1].sum<0)
            {
                dp[i].sum=a[i];
                dp[i].s=i;
                dp[i].e=i;
            }
        }
        sort(dp+1,dp+n+1,cmp);
        if(cas<t)
         {
            printf("Case %d:\n",cas);
            printf("%d %d %d\n",dp[1].sum,dp[1].s,dp[1].e);
            printf("\n");
        }
        else
        {
            printf("Case %d:\n",cas);
            printf("%d %d %d\n",dp[1].sum,dp[1].s,dp[1].e);
        }
    }
    return 0;
}
/*
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
*/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值