poj 1050 To the Max(动态规划处理二维最大子段和)

1、http://poj.org/problem?id=1050

2、题目大意:

给一个N,然后给定一个N*N的二维数组,然后求一个子矩阵,使得其中的数加起来和最大

3、思路:

将二维数组转换成一维数组,假设二维数组是M行N列,那么将二维数组分成N条,用dp[i]记录第i列的和(可以是任意连续长度,for循环就能实现),那么将dp[i]看做一个一个的数,就转换成了一维的数组

核心代码:

 for(int i=1;i<=n;i++)//循环从第一行开始,往下找,i作为每一条的起始点
    {
        memset(dp,0,sizeof(dp));
        for(int j=i;j<=n;j++)
        {
            for(int k=1;k<=n;k++)
            dp[k]+=a[j][k];//求出每一条起点是i,终点是j的长度区间的和
            int sum=maxsum(dp,n);//转换成一维数组后,处理就跟一位数组的代码完全一样
             if(sum>max)
             max=sum;
        }
        memset(dp,0,sizeof(dp));
    }

3、题目:

To the Max
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 34519 Accepted: 18104

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:

9 2
-4 1
-1 8
and has a sum of 15.

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15

 

4、一遍ac的代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[110][110];
int dp[110];
int b[110];
int maxsum(int *bb,int n)
{
    int max=-9999999;
    b[0]=max;
    for(int i=1;i<=n;i++)
    {
        if(b[i-1]>0)
        b[i]=b[i-1]+bb[i];
        if(b[i-1]<0)
        b[i]=bb[i];
        if(b[i]>max)
        max=b[i];
    }
    return max;
}
int main()
{
    int n,max=-99999999;
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=n;j++)
        {
            scanf("%d",&a[i][j]);
        }
    }
    for(int i=1;i<=n;i++)
    {
        memset(dp,0,sizeof(dp));
        for(int j=i;j<=n;j++)
        {
            for(int k=1;k<=n;k++)
            dp[k]+=a[j][k];
            int sum=maxsum(dp,n);
             if(sum>max)
             max=sum;
        }
        memset(dp,0,sizeof(dp));
    }
    printf("%d\n",max);
    return 0;
}
/*
4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2
*/


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值