hdu 1080 Human Gene Functions( 带权值的最长公共子序列)

1、http://acm.hdu.edu.cn/showproblem.php?pid=1080

2、题目大意:

给定两个字符串a,b;其中两个字符串中的字母两两对应都有一个权值,并且两个字符串可以任意添加空格,使得有更多的字符可以对应,例如Given two genes AGTGATG and GTTAG,可以写成

AGTGAT-G
-GT--TAG 这样的最终对应权值是The score of the alignment above is (-3)+5+5+(-2)+(-3)+5+(-3)+5=9.

也可以写成

AGTGATG
-GTTA-G 这样的对应权值之和是(-3)+5+5+(-2)+5+(-1) +5=14,因为空格的加入,可以有很多种不同的权值和,要求的是最大的权值和

由题意不难想到其实类似于求最长公共子序列,只不过不同在于有权值,状态转移方程为

dp[i][j]=maxx(dp[i-1][j-1]+ans[find(a[i])][find(b[j])],dp[i-1][j]+ans[find(a[i])][find('-')],dp[i][j-1]+ans[find('-')][find(b[j])]);

2、题目:

Human Gene Functions

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1555    Accepted Submission(s): 876


Problem Description
It is well known that a human gene can be considered as a sequence, consisting of four nucleotides, which are simply denoted by four letters, A, C, G, and T. Biologists have been interested in identifying human genes and determining their functions, because these can be used to diagnose human diseases and to design new drugs for them.

A human gene can be identified through a series of time-consuming biological experiments, often with the help of computer programs. Once a sequence of a gene is obtained, the next job is to determine its function. One of the methods for biologists to use in determining the function of a new gene sequence that they have just identified is to search a database with the new gene as a query. The database to be searched stores many gene sequences and their functions – many researchers have been submitting their genes and functions to the database and the database is freely accessible through the Internet.

A database search will return a list of gene sequences from the database that are similar to the query gene. Biologists assume that sequence similarity often implies functional similarity. So, the function of the new gene might be one of the functions that the genes from the list have. To exactly determine which one is the right one another series of biological experiments will be needed.

Your job is to make a program that compares two genes and determines their similarity as explained below. Your program may be used as a part of the database search if you can provide an efficient one.

Given two genes AGTGATG and GTTAG, how similar are they? One of the methods to measure the similarity of two genes is called alignment. In an alignment, spaces are inserted, if necessary, in appropriate positions of the genes to make them equally long and score the resulting genes according to a scoring matrix.

For example, one space is inserted into AGTGATG to result in AGTGAT-G, and three spaces are inserted into GTTAG to result in –GT--TAG. A space is denoted by a minus sign (-). The two genes are now of equal length. These two strings are aligned:

AGTGAT-G
-GT--TAG

In this alignment, there are four matches, namely, G in the second position, T in the third, T in the sixth, and G in the eighth. Each pair of aligned characters is assigned a score according to the following scoring matrix.

* denotes that a space-space match is not allowed. The score of the alignment above is (-3)+5+5+(-2)+(-3)+5+(-3)+5=9.

Of course, many other alignments are possible. One is shown below (a different number of spaces are inserted into different positions):

AGTGATG
-GTTA-G

This alignment gives a score of (-3)+5+5+(-2)+5+(-1) +5=14. So, this one is better than the previous one. As a matter of fact, this one is optimal since no other alignment can have a higher score. So, it is said that the similarity of the two genes is 14.


 

Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case consists of two lines: each line contains an integer, the length of a gene, followed by a gene sequence. The length of each gene sequence is at least one and does not exceed 100.


 

Output
The output should print the similarity of each test case, one per line.


 

Sample Input
  
  
2 7 AGTGATG 5 GTTAG 7 AGCTATT 9 AGCTTTAAA


 

Sample Output
  
  
14 21


3、代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char a[110];
char b[110];
int dp[110][110];
int maxx(int a,int b,int c)
{
    int aa=-9999999;
    if(a>aa)
    aa=a;
    if(b>aa)
    aa=b;
    if(c>aa)
    aa=c;
    return aa;
}
int ans[5][5]={
    5,-1,-2,-1,-3,
    -1,5,-3,-2,-4,
    -2,-3,5,-2,-2,
    -1,-2,-2,5,-1,
    -3,-4,-2,-1,100000};
int find(char a)
{
    if(a=='A')
    return 0;
    if(a=='C')
    return 1;
    if(a=='G')
    return 2;
    if(a=='T')
    return 3;
    if(a=='-')
    return 4;
}
int main()
{
    int t,n1,n2,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d ",&n1);
        for(int i=1;i<=n1;i++)
        {
            scanf("%c",&a[i]);
        }
        scanf("%d ",&n2);
        for(int i=1;i<=n2;i++)
        {
            scanf("%c",&b[i]);
        }
        n=max(n1,n2);
        //memset(dp,0,sizeof(dp));
        dp[0][0]=0;
        //printf("&&%d\n",ans[find('-')][find(a[2])]);
        for(int i=1;i<=n;i++)
        {
            dp[0][i]=dp[0][i-1]+ans[find('-')][find(b[i])];
            dp[i][0]=dp[i-1][0]+ans[find(a[i])][find('-')];
        }
        for(int i=1;i<=n1;i++)
        {
            for(int j=1;j<=n2;j++)
            {
               dp[i][j]=maxx(dp[i-1][j-1]+ans[find(a[i])][find(b[j])],dp[i-1][j]+ans[find(a[i])][find('-')],dp[i][j-1]+ans[find('-')][find(b[j])]);
            }
        }
        printf("%d\n",dp[n1][n2]);
    }
    return 0;
}
/*
2
7 AGTGATG
5 GTTAG
7 AGCTATT
9 AGCTTTAAA
*/




 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值