Compromise(最长公共子串变形,打印路径)

1、http://poj.org/problem?id=2250

最长公共子串的变形题,打印路径,较好的题目,好好看。。。

第一遍错在maxx()函数了,至今不知为何错了,看别人代码改对了,思考中。。。

2、题目大意:给定两篇文章,单词与单词之间以空格隔开,输出两篇文章中最长序列的单词,打印出来

此题与最长公共子串基本类似,不同在于需要打印出最长公共子串,并且需要处理的是一个一个的单词

但是输出的时候需要注意,就是要将每次的决策给记录下来,方便输出的时候用,每次输出的时候是当他们相等的时候决策就输出。

Compromise
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5238 Accepted: 2384 Special Judge

Description

In a few months the European Currency Union will become a reality. However, to join the club, the Maastricht criteria must be fulfilled, and this is not a trivial task for the countries (maybe except for Luxembourg). To enforce that Germany will fulfill the criteria, our government has so many wonderful options (raise taxes, sell stocks, revalue the gold reserves,...) that it is really hard to choose what to do.

Therefore the German government requires a program for the following task:
Two politicians each enter their proposal of what to do. The computer then outputs the longest common subsequence of words that occurs in both proposals. As you can see, this is a totally fair compromise (after all, a common sequence of words is something what both people have in mind).

Your country needs this program, so your job is to write it for us.

Input

The input will contain several test cases.
Each test case consists of two texts. Each text is given as a sequence of lower-case words, separated by whitespace, but with no punctuation. Words will be less than 30 characters long. Both texts will contain less than 100 words and will be terminated by a line containing a single '#'.
Input is terminated by end of file.

Output

For each test case, print the longest common subsequence of words occuring in the two texts. If there is more than one such sequence, any one is acceptable. Separate the words by one blank. After the last word, output a newline character.

Sample Input

die einkommen der landwirte
sind fuer die abgeordneten ein buch mit sieben siegeln
um dem abzuhelfen
muessen dringend alle subventionsgesetze verbessert werden
#
die steuern auf vermoegen und einkommen
sollten nach meinung der abgeordneten
nachdruecklich erhoben werden
dazu muessen die kontrollbefugnisse der finanzbehoerden
dringend verbessert werden
#

Sample Output

die einkommen der abgeordneten muessen dringend verbessert werden

 

3、ac代码:

#include<stdio.h>
#include<string.h>
char s1[110][110];
char s2[110][110];
char temp[110];
int dp[110][110];
int mark[110][110];
int ans[110];
int sum;
int maxx(int a,int b,int c,int i,int j)
{
    if(a>b&&a>c)
    {
        mark[i][j]=1;
        return a;
    }
    if(b>a&&b>c)
    {
        mark[i][j]=2;
        return b;
    }
    //else if(c>=a&&c>=b)//错在三个数abc可能有相等,那么最大值就不能简单的判断if(c>a&&c>b),错在没加等号
    //{
        mark[i][j]=3;
        return c;
    //}
}
int same(int i,int j)
{
    if(strcmp(s1[i],s2[j])==0)
    return 1;
    else
    return 0;
}
void print(int i,int j)
{
    if(mark[i][j]==1)
    {
        ans[sum++]=i-1;
        print(i-1,j-1);
    }
    else if(mark[i][j]==2)
    {
        print(i-1,j);
    }
    else if(mark[i][j]==3)
    print(i,j-1);
}
int main()
{

    while(scanf("%s",temp)!=EOF)
    {
        int len1=0,len2=0;
        strcpy(s1[len1++],temp);
        while(scanf("%s",temp))
        {
            if(strcmp(temp,"#")==0)
            break;
            strcpy(s1[len1++],temp);
        }
        while(scanf("%s",temp))
        {
            if(strcmp(temp,"#")==0)
            break;
            strcpy(s2[len2++],temp);
        }
        memset(dp,0,sizeof(dp));
        memset(mark,0,sizeof(mark));
        for(int i=1;i<=len1;i++)
        {
            for(int j=1;j<=len2;j++)
            {
                dp[i][j]=maxx(dp[i-1][j-1]+same(i-1,j-1),dp[i-1][j],dp[i][j-1],i,j);
            }
        }
        sum=0;
        print(len1,len2);
        for(int k=sum-1;k>=0;k--)
        {
            //if(k==sum-1)
           // printf("%s",s1[ans[k]]);
            //else
            printf("%s ",s1[ans[k]]);
        }
        printf("\n");
    }
    return 0;
}
/*
die einkommen der landwirte
sind fuer die abgeordneten ein buch mit sieben siegeln
um dem abzuhelfen
muessen dringend alle subventionsgesetze verbessert werden
#
die steuern auf vermoegen und einkommen
sollten nach meinung der abgeordneten
nachdruecklich erhoben werden
dazu muessen die kontrollbefugnisse der finanzbehoerden
dringend verbessert werden
#

*/


 

wrong answer 的代码,错在maxx()函数

#include<stdio.h>
#include<string.h>
char s1[110][110];
char s2[110][110];
char temp[110];
int dp[110][110];
int mark[110][110];
int ans[110];
int sum;
int maxx(int a,int b,int c,int i,int j)//此函数错误
{
    if(a>b&&a>c)
    {
        mark[i][j]=1;
        return a;
    }
    else if(b>a&&b>c)
    {
        mark[i][j]=2;
        return b;
    }
    else if(c>=a&&c>=b)//错在三个数abc可能有相等,那么最大值就不能简单的判断if(c>a&&c>b),错在没加等号
    {
        mark[i][j]=3;
        return c;
    }
}
int same(int i,int j)
{
    if(strcmp(s1[i],s2[j])==0)
    return 1;
    else
    return 0;
}
void print(int i,int j)
{
    if(mark[i][j]==1)
    {
        ans[sum++]=i-1;
        print(i-1,j-1);
    }
    else if(mark[i][j]==2)
    {
        print(i-1,j);
    }
    else if(mark[i][j]==3)
    print(i,j-1);
}
int main()
{

    while(scanf("%s",temp)!=EOF)
    {
        int len1=0,len2=0;
        strcpy(s1[len1++],temp);
        while(scanf("%s",temp))
        {
            if(strcmp(temp,"#")==0)
            break;
            strcpy(s1[len1++],temp);
        }
        while(scanf("%s",temp))
        {
            if(strcmp(temp,"#")==0)
            break;
            strcpy(s2[len2++],temp);
        }
        memset(dp,0,sizeof(dp));
        memset(mark,0,sizeof(mark));
        for(int i=1;i<=len1;i++)
        {
            for(int j=1;j<=len2;j++)
            {
                dp[i][j]=maxx(dp[i-1][j-1]+same(i-1,j-1),dp[i-1][j],dp[i][j-1],i,j);
            }
        }
        sum=0;
        print(len1,len2);
        for(int k=sum-1;k>=0;k--)
        {
            //if(k==sum-1)
           // printf("%s",s1[ans[k]]);
            //else
            printf("%s ",s1[ans[k]]);
        }
        printf("\n");
    }
    return 0;
}
/*
die einkommen der landwirte
sind fuer die abgeordneten ein buch mit sieben siegeln
um dem abzuhelfen
muessen dringend alle subventionsgesetze verbessert werden
#
die steuern auf vermoegen und einkommen
sollten nach meinung der abgeordneten
nachdruecklich erhoben werden
dazu muessen die kontrollbefugnisse der finanzbehoerden
dringend verbessert werden
#

*/


 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值