Judges' Time Calculation (周赛模拟题)


1、
http://acm.sdut.edu.cn/sdutoj/showproblem.php?pid=2577&cid=1164

2、题目:

Judges' Time Calculation

Time Limit: 1000MS    Memory limit: 65536K

题目描述

In our region, the contest traditionally starts at 12:30 and lasts for 5 hours. If you are able to submit a solution at 12:39, the wise judges would determine that 9 minutes had elapsed since the start of the contest. Sadly, as the day grows longer, the judges have more trouble doing the calculations accurately (how quickly can you determine the elapsed time for a 3:21 submission?)
Having struggled for many years, the judges developed the following system. Before the contest starts, they place the following table on the board at the front of the room
                                                            
When a problem is submitted with a given time-stamp, they determine which row of the table to use, based upon the hour of the time-stamp. Then, the formula in the right column is used to compute the number of elapsed minutes. For example, with a submission time of 12:39, the top row is applied with XX=39, leading to the elapsed minutes calculated as 39 - 30 = 9. For a program submitted at 3:21, the fourth row is used to calculate 21 + 150 = 171 elapsed minutes.
Your goal is to develop a program that generates the appropriate table given knowledge of the starting time and duration of a contest.

输入

The input starts with a line containing a single integer 1 ≤ N ≤ 30 that is the number of cases.
Following this are N lines, with each line containing integral values SH, SM, DH, DM separated by spaces. The values 1 ≤ SH ≤ 12 and 0 ≤ SM ≤ 59 respectively represent the hour and minute at which a contest starts. The values 0 ≤ DH ≤ 10 and 0 ≤ DM ≤ 59 represent the duration of the contest in terms of hours and minutes. A contest will last at least 1 minute and at most 10 hours and 59 minutes. This allows us to omit any A.M. or P.M. designations for the times.

输出

For each case, you are to produce a table formatted as shown in the Example Output. Any row in which the hour designator is a single digit (e.g., 5:XX) should have a single leading space, as should the header of the table just before the word "time".
The table must have a row for every hour block in which a program might be submitted. Assume that the earliest possible submission is precisely the contest starting time (i.e., 0 elapsed minutes), and that the latest possible submission has an elapsed time of the full duration of the contest (e.g., 5:30 in our region).

示例输入

3 
12 30 5 0 
7 0 2 59 
9 59 4 1 

示例输出

------+---------
 time | elapsed
------+---------
12:XX | XX - 30
 1:XX | XX + 30
 2:XX | XX + 90
 3:XX | XX + 150
 4:XX | XX + 210
 5:XX | XX + 270
------+---------
 time | elapsed
------+---------
 7:XX | XX
 8:XX | XX + 60
 9:XX | XX + 120
------+---------
 time | elapsed
------+---------
 9:XX | XX - 59
10:XX | XX + 1
11:XX | XX + 61
12:XX | XX + 121
 1:XX | XX + 181
 2:XX | XX + 241

 

3、代码

#include<stdio.h>
#include<string.h>
int main()
{
    int n,a,b,c,d;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%d%d%d%d",&a,&b,&c,&d);
        printf("------+---------\n");
        printf(" time | elapsed\n");
        printf("------+---------\n");
        if(b==0&&a>=1&&a<=9)
        printf(" %d:XX | XX\n",a);
        else if(b==0&&a>=10&&a<=12)
        printf("%d:XX | XX\n",a);
        else if(b!=0&&a>=1&&a<=9)
        printf(" %d:XX | XX - %d\n",a,b);
        else if(b!=0&&a>=10&&a<=12)
        printf("%d:XX | XX - %d\n",a,b);
        if(b+d<60)
        {
            int count=0-b,aa=a;
            for(int i=1;i<=c;i++)
            {
                aa++;
                count+=60;
                if(aa%12==0)
                {
                    printf("12:XX | XX + %d\n",count);
                }
                else if(aa%12>=1&&aa%12<=9)
                printf(" %d:XX | XX + %d\n",aa%12,count);
                else
                {
                    printf("%d:XX | XX + %d\n",aa%12,count);
                }
            }
        }
        else
        {
            int count=0-b,aa=a;
            for(int i=1;i<=c+1;i++)
            {
                aa++;
                count+=60;
                if(aa%12==0)
                {
                    printf("12:XX | XX + %d\n",count);
                }
                else if(aa%12>=1&&aa%12<=9)
                printf(" %d:XX | XX + %d\n",aa%12,count);
                else
                {
                    printf("%d:XX | XX + %d\n",aa%12,count);
                }
            }
        }
    }
    return 0;
}
/*
3
12 30 5 0
7 0 2 59
9 59 4 1
*/


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值