D - The Lucky Week

Edward, the headmaster of the Marjar University, is very busy every day and always forgets the date.

There was one day Edward suddenly found that if Monday was the 1st, 11th or 21st day of that month, he could remember the date clearly in that week. Therefore, he called such week "The Lucky Week".

But now Edward only remembers the date of his first Lucky Week because of the age-related memory loss, and he wants to know the date of the N-th Lucky Week. Can you help him?

Input

There are multiple test cases. The first line of input is an integer T indicating the number of test cases. For each test case:

The only line contains four integers YMD and N (1 ≤ N ≤ 109) indicating the date (Y: year, M: month, D: day) of the Monday of the first Lucky Week and the Edward's query N.

The Monday of the first Lucky Week is between 1st Jan, 1753 and 31st Dec, 9999 (inclusive).

<h4< dd="">Output

For each case, print the date of the Monday of the N-th Lucky Week.

<h4< dd="">Sample Input
2
2016 4 11 2
2016 1 11 10
<h4< dd="">Sample Output
2016 7 11
2017 9 11

#include <bits/stdc++.h>
using namespace std;

long long y, m, d, n, m1, yy, d1,x;
int main()
{
    //freopen("c.txt", "w", stdout);
    long long i, j, k;
    long long t;
    scanf("%lld", &t);
    while(t--)
    {
        scanf("%lld %lld %lld %lld", &y, &m, &d, &n);
        m1 = m;yy = y;d1 = d;
        long long sum = 0;
        long long aa=0;
        n--;
        x=n/2058;
        y+=400*x;
        n%=2058;
        while(n)
        {
            long long flag = 0;
            if(y % 4 == 0 && y % 100 != 0 || y % 400 == 0)flag = 1;
            if(m == 5 || m == 7 || m == 10 || m == 12 || m == 8 || m == 1 || m == 3)
            {
                if(d == 1 || d == 11){d += 10; sum += 10;}
                else if(d == 21){d = 1; m++; if(m == 13){y++;m = 1;}sum += 11;}
            }
            else if(m == 4 || m == 6 || m == 9 || m == 11)
            {
                if(d == 1 || d == 11){d += 10; sum+= 10;}
                else if(d == 21){d = 1; m++; if(m == 13){y++;m = 1;}sum += 10;}
            }
            else
            {
                if(d == 1 || d == 11){d += 10; sum+= 10;}
                else if(d == 21){
                        d = 1; m++; if(m == 13){y++;m = 1;}//sum += 10;
                        if(flag == 1)sum += 9;
                        else sum += 8;
                    }
            }
            if(sum % 7 == 0)
            {

                //aa++;cout << y << " " << m << " " << d << " " << aa <<endl;
                n--;
            }
            sum%=7;
        }
        cout << y << " " << m << " " << d << endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值