The Lucky Week(打表找规律)

The Lucky Week

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Edward, the headmaster of the Marjar University, is very busy every day and always forgets the date.

There was one day Edward suddenly found that if Monday was the 1st, 11th or 21st day of that month, he could remember the date clearly in that week. Therefore, he called such week "The Lucky Week".

But now Edward only remembers the date of his first Lucky Week because of the age-related memory loss, and he wants to know the date of the N-th Lucky Week. Can you help him?

Input

There are multiple test cases. The first line of input is an integer T indicating the number of test cases. For each test case:

The only line contains four integers YMD and N (1 ≤ N ≤ 109) indicating the date (Y: year, M: month, D: day) of the Monday of the first Lucky Week and the Edward's query N.

The Monday of the first Lucky Week is between 1st Jan, 1753 and 31st Dec, 9999 (inclusive).

Output

For each case, print the date of the Monday of the N-th Lucky Week.

Sample Input
2
2016 4 11 2
2016 1 11 10
Sample Output
2016 7 11
2017 9 11

Author:  GAN, Tiansheng

Source: The 13th Zhejiang Provincial Collegiate Programming Contest

题意:我们认为日期的天数为1,11,21,并且是周一的为Lucky Week;现在给出第一个lucky week的日期,求第N个的lucky week;

1:四百年一轮回,从闰年和平年的判定可以推出 

2:由上一条可以用程序判断出每四百年有2058个天为1,11,21的星期一。(打表)

打表找规律:

#include<bits/stdc++.h>
#define ll long long
using namespace std;
ll mod = 1e9+7;
const int maxn  = 1e5+7;

int y, m, d, n;
int rm[13] = {0, 31, 29, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};
int brm[13] = {0, 31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};
bool ru(int c) {
    if(c%400 == 0) return true;
    else if(c%100 != 0 && c%4 == 0) return true;
    else return false;
}

void solve()
{
    if(ru(y)) {
        if(d > rm[m]) {
            d -= rm[m];
            m++;
        }
    } else {
        if(d > brm[m]) {
            d -= brm[m];
            m++;
        }
    }
    if(m > 12) {
                m = 1;
                y++;
    }
}




int main()
{
    while(1) {
        scanf("%d%d%d", &y, &m, &d);
        int sum = 0, a = y,b = m, c = d;
        while(1)
        {
            if(d == 1||d == 11||d == 21) {
                    sum++;
            }
            d += 7;
            solve();
            if((y - a>= 400)&&(m >= b)&&(d >= c)) break;
        }
        cout << sum << endl;
    }
    return 0;
}



代码:

#include<bits/stdc++.h>
#define ll long long
using namespace std;
ll mod = 1e9+7;
const int maxn  = 1e5+7;

int y, m, d, n;
int rm[13] = {0, 31, 29, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};
int brm[13] = {0, 31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};
bool ru(int c) {
    if(c%400 == 0) return true;
    else if(c%100 != 0 && c%4 == 0) return true;
    else return false;
}

void solve()
{
    if(ru(y)) {
        if(d > rm[m]) {
            d -= rm[m];
            m++;
        }
    } else {
        if(d > brm[m]) {
            d -= brm[m];
            m++;
        }
    }
    if(m > 12) {
                m = 1;
                y++;
    }
}


int main() {
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d%d%d", &y, &m, &d, &n);
        y += (n/2058) * 400;
        n %= 2058;

        while(n)
        {
            if(d == 1||d == 11||d == 21) n--;
            if(n == 0) break;
            d += 7;
            solve();
        }
        printf("%d %d %d\n", y, m, d);
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值