hdu 1024 Max Sum Plus Plus

Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^

Input Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 ... S n.
Process to the end of file.
Output Output the maximal summation described above in one line.
Sample Input
1 3 1 2 3
2 6 -1 4 -2 3 -2 3
Sample Output
6
8


        
  
Hint
Huge input, scanf and dynamic programming is recommended.

        
 

题意

从m个数中选n段,使累加和的累积和最大

思路

dp

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;
int a[1100000];
int dp[1010000];//表示前j个分成i-1分最大
int Max[1000100];//表示前j个分成i分最大
int main()
{
    int n,m,maxx;
    while(cin>>n>>m)
    {
        for(int i=1;i<=m;i++)
        {
            scanf("%d",&a[i]);
        }
        memset(dp,0,sizeof(dp));
        memset(Max,0,sizeof(Max));
        for(int i=1;i<=n;i++)
        {
            maxx = -0x3f3f3f3f;//刚上来必须新分一组
            for(int j=i;j<=m;j++)
            {
                dp[j]=max(dp[j-1]+a[j],Max[j-1]+a[j]);//判断分成i组,第j个是新分一组还是分到前一组
                Max[j-1] = maxx;//前j-1结尾分成i组最大值
                maxx = max(maxx,dp[j]);//前j个分成i组最大值
            }
        }
        cout<<maxx<<endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值