Pangu and Stones HihoCoder - 1636 (区间dp)

In Chinese mythology, Pangu is the first living being and the creator of the sky and the earth. He woke up from an egg and split the egg into two parts: the sky and the earth.

At the beginning, there was no mountain on the earth, only stones all over the land.

There were N piles of stones, numbered from 1 to N. Pangu wanted to merge all of them into one pile to build a great mountain. If the sum of stones of some piles was S, Pangu would need S seconds to pile them into one pile, and there would be S stones in the new pile.

Unfortunately, every time Pangu could only merge successive piles into one pile. And the number of piles he merged shouldn't be less than L or greater than R.

Pangu wanted to finish this as soon as possible.

Can you help him? If there was no solution, you should answer '0'.

Input

There are multiple test cases.

The first line of each case contains three integers N,L,R as above mentioned (2<=N<=100,2<=L<=R<=N).

The second line of each case contains N integers a1,a2 …aN (1<= ai  <=1000,i= 1…N ), indicating the number of stones of  pile 1, pile 2 …pile N.

The number of test cases is less than 110 and there are at most 5 test cases in which N >= 50.

Output

For each test case, you should output the minimum time(in seconds) Pangu had to take . If it was impossible for Pangu to do his job, you should output  0.

Sample Input

3 2 2
1 2 3
3 2 3
1 2 3
4 3 3
1 2 3 4

Sample Output

9
6
0
题意

N堆石子,和并成一堆,问最小花费,每次最小合并L最多合并R堆

思路

区间DP,最后是由L到R堆合并来的,先求和并到L到R堆,从小区间推大区间

#include <bits/stdc++.h>

using namespace std;
const int MAX = 105;
const int inf = 0x3f3f3f3f;
int a[MAX],dp[MAX][MAX][MAX],sum[MAX][MAX];
int main()
{
    int n,m,i,j,k,l,r;
    while(scanf("%d%d%d",&n,&l,&r) != EOF)
    {
        for(i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        memset(dp,inf,sizeof(dp));
        for(i=1;i<=n;i++) //求区间和
        {
            sum[i][i-1] = 0;
            for(j=i;j<=n;j++) sum[i][j] = sum[i][j-1] + a[j];
        }
        for(i=1;i <=n;i++) dp[i][i][1] = 0;
        for(int len=0;len<n;len++) //先计算小区间,区间长度从0开始
        {
            for(i=1;i+len<=n;i++)//区间左边
            {
                j = i+len;//区间右边
                for(k=min(j-i+1,r);k>=2;k--)//区间最少分成两个,最所多r
                {
                    for(int p = i;p<j&&j-p>=k-1;p++)//分成1分和k-1分
                    {
                        dp[i][j][k] = min(dp[i][j][k],dp[i][p][1]+dp[p+1][j][k-1]);
                    }
                    if(k>=l)dp[i][j][1] = min(dp[i][j][1],dp[i][j][k]+sum[i][j]);
                    //合并
                }
            }
        }

        if(dp[1][n][1] == inf)
             printf("0\n");
        else printf("%d\n",dp[1][n][1]);
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值