Pangu and Stones HihoCoder - 1636

In Chinese mythology, Pangu is the first living being and the creator of the sky and the earth. He woke up from an egg and split the egg into two parts: the sky and the earth.

At the beginning, there was no mountain on the earth, only stones all over the land.

There were N piles of stones, numbered from 1 to N. Pangu wanted to merge all of them into one pile to build a great mountain. If the sum of stones of some piles was S, Pangu would need S seconds to pile them into one pile, and there would be S stones in the new pile.

Unfortunately, every time Pangu could only merge successive piles into one pile. And the number of piles he merged shouldn't be less than L or greater than R.

Pangu wanted to finish this as soon as possible.

Can you help him? If there was no solution, you should answer '0'.

Input

There are multiple test cases.

The first line of each case contains three integers N,L,R as above mentioned (2<=N<=100,2<=L<=R<=N).

The second line of each case contains N integers a1,a2 …aN (1<= ai  <=1000,i= 1…N ), indicating the number of stones of  pile 1, pile 2 …pile N.

The number of test cases is less than 110 and there are at most 5 test cases in which N >= 50.

Output

For each test case, you should output the minimum time(in seconds) Pangu had to take . If it was impossible for Pangu to do his job, you should output  0.

Sample Input

3 2 2
1 2 3
3 2 3
1 2 3
4 3 3
1 2 3 4

Sample Output

9
6
0

 

定义: 一定要没有歧义,清楚。  对于各种情况,应该是什么值。 尤其是初始状态

 

#include<bits/stdc++.h>
#include<stdlib.h>
using namespace std;

typedef long long LL;
#define rep(i,a,b) for(int i=a;i<b;++i)
#define per(i,a,b) for(int i=b-1;i>=a;--i)

const int INF=0x3f3f3f3f;
const int N=110;
int val[N],sum[N];
int dp[N][N][N];
/*
11 3 5
187 314 475 23 169 19 788 906 959 392 203
6621
*/
int main()
{
	//freopen("123.txt","r",stdin);
	//freopen("789.txt","w",stdout);
    int n,L,R;
    while(scanf("%d %d %d",&n,&L,&R)==3) {
        for(int i=1; i<=n; i++) {
            scanf("%d",&val[i]);
            sum[i]=sum[i-1]+val[i];
        }
        rep(i,0,n+1) {
            rep(j,0,n+1) {
                rep(k,0,n+1) {
                    dp[i][j][k]=INF;
                }
            }
        }
		for(int len=1;len<=n;len++){
        	for(int st=1;st+len-1<=n;st++){
        		dp[st][st+len-1][len]=0;
			}
		}
        //rep(i,1,n+1)dp[i][i][1]=val[i];
        for(int len=1; len<=n; len++) {
            for(int st=1; st+len-1<=n; st++) {
                int ed=st+len-1;
				
				//只是更新操作,不合并。 看看到达当前状态的有多少种情况。  为下一层做准备
                for(int k=2; k<=len; k++) {
                    for(int j=st+k-1-1; j<ed; j++) {
                       // printf("st:%d j:%d  %d    j+1:%d ed:%d  %d\n",st,j,dp[st][j][k-1],j+1,ed,dp[j+1][ed][1]);
                        dp[st][ed][k]=min(dp[st][ed][k],dp[st][j][k-1]+dp[j+1][ed][1]);//+sum[ed]-sum[st-1]
                    }
                }
                //合并操作,严格按照 给定的区间合并
                for(int k=L; k<=R; k++) {
                    for(int j=st+k-1-1; j<=ed; j++) {
						int t=(j==ed)?dp[st][ed][k]+sum[ed]-sum[st-1]:dp[st][j-1][k-1]+dp[j][ed][1]+sum[ed]-sum[st-1];
						//printf("st:%d j:%d  %d    j+1:%d ed:%d  %d\n",st,j,dp[st][j][k-1],j+1,ed,dp[j+1][ed][1]);
                        dp[st][ed][1]=min(dp[st][ed][1],t);
                    }
                }
            }
        }
        if(dp[1][n][1]>=INF)printf("0\n");
        else printf("%d\n",dp[1][n][1]);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值