dp Problem B:Common Subsequence(HDU 1159)

Problem B

Time Limit : 2000/1000ms (Java/Other)   Memory Limit :65536/32768K (Java/Other)

Total Submission(s) : 1   Accepted Submission(s) : 1

Problem Description

A subsequence of a givensequence is the given sequence with some elements (possible none) left out.Given a sequence X = &lt;x1, x2, ..., xm&gt; another sequence Z =&lt;z1, z2, ..., zk&gt; is a subsequence of X if there exists a strictlyincreasing sequence &lt;i1, i2, ..., ik&gt; of indices of X such thatfor all j = 1,2,...,k, xij = zj. For example, Z = &lt;a, b, f, c&gt; isa subsequence of X = &lt;a, b, c, f, b, c&gt; with index sequence&lt;1, 2, 4, 6&gt;. Given two sequences X and Y the problem is to findthe length of the maximum-length common subsequence of X and Y. <br>Theprogram input is from a text file. Each data set in the file contains twostrings representing the given sequences. The sequences are separated by anynumber of white spaces. The input data are correct. For each set of data theprogram prints on the standard output the length of the maximum-length commonsubsequence from the beginning of a separate line. <br>

 

 

Sample Input

abcfbc abfcab

programming contest

abcd mnp

 

 

Sample Output

4

2

0

算法分析:

最长公共子序列  典型算法  详细解释【点这里

AC代码:

 

#include<bits/stdc++.h>
using namespace std;
#define MAX 5005
int f[MAX][MAX];//必须放在外面
int main()
{
    int i,j;
       string x,y;
     while(cin>>x>>y)
       {
      int lx=x.length();//x序列长度
       int ly=y.length();//y序列长度
       for(i=1;i<=lx;i++)
        for(j=1;j<=ly;j++)
       {
           f[i][j]=max(f[i-1][j],f[i][j-1]);
           if(x[i-1]==y[j-1])
            f[i][j]=max(f[i][j],f[i-1][j-1]+1);
       }
       printf("%d\n",f[lx][ly]);
       }

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值