POJ 3258 River Hopscotch  二分

River Hopscotch

Time Limit: 2000MS

 

Memory Limit: 65536K

Total Submissions: 19217

 

Accepted: 7993

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers: LN, and M 
Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

Source

USACO 2006 December Silver

算法分析:

题意:

一条河宽为L,河中有n块石头,并且每块石头距河岸的距离已知,现在将河中的m块石头移去,求相邻两块石头的最小距离的最大值。

分析:

最小距离的最大值,二分实现,如何删除石头,看代码。

代码实现:

#include<cstdio>  
#include<cstring>  
#include<cstdlib>  
#include<cctype>  
#include<cmath>  
#include<iostream>  
#include<sstream>  
#include<iterator>  
#include<algorithm>  
#include<string>  
#include<vector>  
#include<set>  
#include<map>  
#include<stack>  
#include<deque>  
#include<queue>  
#include<list>  
using namespace std;  
const double eps = 1e-8;  
typedef long long LL;  
typedef unsigned long long ULL;  
const int INT_INF = 0x3f3f3f3f;  
const int INT_M_INF = 0x7f7f7f7f;  
const LL LL_INF = 0x3f3f3f3f3f3f3f3f;  
const LL LL_M_INF = 0x7f7f7f7f7f7f7f7f;  
const int dr[] = {0, 0, -1, 1, -1, -1, 1, 1};  
const int dc[] = {-1, 1, 0, 0, -1, 1, -1, 1};  
const int MOD = 1e9 + 7;  
const double pi = acos(-1.0);  
const int MAXN = 1e5 + 10;  
const int MAXT = 10000 + 10;  
const int M=50010;
int a[M];
int main()
{
	int L,n,m;
	while(scanf("%d%d%d",&L,&n,&m)!=EOF)
	{
		for(int i=1;i<=n;i++)
			scanf("%d",&a[i]);
		a[0]=0;a[n+1]=L;    //补上起点,终点
		sort(a,a+n+2);   //从小到大排序
		int l=0,r=L,mid;
		int ans;
		while(l<=r)
		{
			int k=0,sum=0;
			mid=(l+r)/2;
			for(int i=1;i<=n+1;i++)
			{
				if(a[i]-a[k]<mid)    //如果mid大于当前距离,说明mid就不是最短距离 ,所以移除石头
				{
					sum++;           //移除石头数量
				}
				else k=i;     //更新移除的石头
			}
			if(sum>m)          //删除过多,mid偏大
			{
				r=mid-1;
			}
			else
			{
				l=mid+1;
				ans=mid;
			}
		  
		}
		printf("%d\n",ans);
	}
    return 0;
}

java代码

import java.io.BufferedInputStream;
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStream;
import java.io.InputStreamReader;
import java.util.Arrays;
import java.util.Scanner;
import java.util.Set;
import java.util.StringTokenizer;
import java.util.TreeSet;
public class Main {
	public static void main(String[] args) throws IOException {
		Scanner in = new Scanner (new BufferedInputStream(System.in));
		//Scanner in = new Scanner(new BufferedInputStream(System.in));
	    Reader.init(System.in);
	    int L=in.nextInt();
	    int n=in.nextInt();
	    int m=in.nextInt();
	    
	    int [] a=new int[n+5];
	    
	   for(int i=1;i<=n;i++)
	    {
	    	a[i]=in.nextInt();
	    }
	   
	   Arrays.sort(a,1,n+1);
	   int ans=0;
	   int l=-1,r=L;
	   while(l<r)
	   {
		   int mid=(l+r+1)>>1;
	       if(f(a,mid,L,n)<=m)
              l=mid;
	       else
	    	  r=mid-1;
	   }
	   System.out.println(l);
	}

	private static int f(int[] a, int mid, int l, int n) {
		// TODO 自动生成的方法存根
		int sum=0;
		int pos=0;
		for(int i=1;i<=n;i++)
		{
			if(a[i]-pos<mid)
			{
				//if(mid==4)
				//System.out.println(pos+"    "+a[i]);
				sum++;
			}
			else
				pos=a[i];
		}
		if(l-pos<mid)
			sum++;
		//System.out.println(mid+" "+sum);
		return sum;
	}		
}
class Reader 
{ 
    static BufferedReader reader; 
    static StringTokenizer tokenizer; 
 
    static void init(InputStream input) 
    { 
        reader = new BufferedReader(new InputStreamReader(input)); 
        tokenizer = new StringTokenizer(""); 
    } 
 
    static String next() throws IOException 
    { 
        while(!tokenizer.hasMoreTokens()) 
        { 
            String str=reader.readLine();
            //System.out.println(str);
            tokenizer = new StringTokenizer(str); 
        } 
        return tokenizer.nextToken(); 
    } 
 
    static int nextInt() throws  IOException 
    { 
        return Integer.parseInt(next()); 
    } 
 
    static double nextDouble() throws IOException 
    { 
        return Double.parseDouble(next()); 
 
    } 
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值