hdu3652 B-number 数位dp模板题

B-number

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3376 Accepted Submission(s): 1891


 

Problem Description

A wqb-number, or B-number for short, is a non-negative integer whose decimal form contains the sub- string "13" and can be divided by 13. For example, 130 and 2613 are wqb-numbers, but 143 and 2639 are not. Your task is to calculate how many wqb-numbers from 1 to n for a given integer n.

 

Input

Process till EOF. In each line, there is one positive integer n(1 <= n <= 1000000000).

 

Output

Print each answer in a single line.

 

Sample Input

 

13 100 200 1000

 

Sample Output

 

1 1 2 2

 

Author

wqb0039

 

Source

2010 Asia Regional Chengdu Site —— Online Contest 

 

题意:找出1~n有多少个数既含有13又能被13整除。

分析:数位DP模板题,记忆化搜索配合数位dp求解。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
using namespace std;
typedef long long ll;
int a[20];
ll dp[25][3][13];
//dp[i][mod][j]:长度为i,余数为mod,状态为j,

ll dfs(int pos,int mod,int sta,bool limit)
//sta==0,高位没有13
//sta==1,高位没有13 但末尾1
//sta==2,高位有13
{
    if(pos==-1) return (mod==0)&&(sta==2);
    if(!limit && dp[pos][sta][mod]!=-1) return dp[pos][sta][mod];
    int up=limit ? a[pos] : 9;
	ll tmp=0;
    for(int i=0;i<=up;i++)
    {
    	int tmod = (mod*10+i)%13;
    	int tsta=sta;   //很巧妙的一步
    	 if(sta==0&&i==1)//高位没有13,末尾不是1,现在添1
    	 	tsta=1;
		 else if(sta==1&&i!=1&&i!=3)//高位没有13,末尾是1,但添加不是3也不是1,返回sta=0状态
		 	tsta=0;
		 else if(sta==1&&i==3)//高位不含13,且末尾是1,末尾添加3返回2的状态
		 	tsta=2;
        tmp+=dfs(pos-1,tmod,tsta,limit && i==a[pos]);
    }
    if(!limit) dp[pos][sta][mod]=tmp;
    return tmp;
}
ll solve(int x)
{
    int pos=0;
    while(x)
    {
        a[pos++]=x%10;
        x/=10;
    }
   
    return dfs(pos-1,0,0,true);
}
int main()
{
    ll n;
    //memset(dp,-1,sizeof dp);可优化
    while(~scanf("%lld",&n))
    {
        memset(dp,-1,sizeof dp);
        printf("%lld\n",solve(n));
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值