G - B-number

A wqb-number, or B-number for short, is a non-negative integer whose decimal form contains the sub- string "13" and can be divided by 13. For example, 130 and 2613 are wqb-numbers, but 143 and 2639 are not. Your task is to calculate how many wqb-numbers from 1 to n for a given integer n.

Input
Process till EOF. In each line, there is one positive integer n(1 <= n <= 1000000000).
Output
Print each answer in a single line.
Sample Input
13
100
200
1000
Sample Output
1
1
2
2


题目大概:

找出1到n之间的含有连续数列13并能整除13的数的个数。

思路:

数位dp基础题,

代码:


#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
int a[20];
int dp[20][20][15][15];

int sove(int pos,int b,int qian,int bb,int limit)
{
    if(pos==-1)return bb&&!b;
    if(!limit&&dp[pos][b][qian][bb]!=-1)return dp[pos][b][qian][bb];
    int sum=0;
    int end=limit?a[pos]:9;
    for(int i=0;i<=end;i++)
    {
        if(qian==1&&i==3)sum+=sove(pos-1,(b*10+i)%13,i,1,limit&&(i==a[pos]));
        else sum+=sove(pos-1,(b*10+i)%13,i,bb,limit&&(i==a[pos]));
    }
    if(!limit)dp[pos][b][qian][bb]=sum;
    return sum;
}

int go(int x)
{
    int pos=0;
    while(x)
    {
        a[pos++]=x%10;
        x/=10;
    }
    return sove(pos-1,0,0,0,1);
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {   memset(dp,-1,sizeof(dp));

        printf("%d\n",go(n));
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值