poj 3208 Apocalypse Someday 数位dp+二分答案

Apocalypse Someday

Time Limit: 1000MS Memory Limit: 131072K
Total Submissions: 2203 Accepted: 1110

Description

The number 666 is considered to be the occult “number of the beast” and is a well used number in all major apocalypse themed blockbuster movies. However the number 666 can’t always be used in the script so numbers such as 1666 are used instead. Let us call the numbers containing at least three contiguous sixes beastly numbers. The first few beastly numbers are 666, 1666, 2666, 3666, 4666, 5666…

Given a 1-based index n, your program should return the nth beastly number.

Input

The first line contains the number of test cases T (T ≤ 1,000).

Each of the following T lines contains an integer n (1 ≤ n ≤ 50,000,000) as a test case.

Output

For each test case, your program should output the nth beastly number.

Sample Input

3
2
3
187

Sample Output

1666
2666
66666

Source

POJ Monthly--2007.03.04, Ikki, adapted from TCHS SRM 2 ApocalypseSomeday

 

题意:

求第nn小的数位中含有三个连续的6的数。

简单数位DP+二分

#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;
typedef long long ll;
ll dp[30][30];
int a[30];
ll dfs(int pos,int sta,bool limit)
//计算
{
	if(pos==-1){
		return sta==3;
	}
	if(!limit&&dp[pos][sta]!=-1) 
	return dp[pos][sta];
	int up=limit?a[pos]:9;
	ll tmp=0;
	for(int i=0;i<=up;i++)
	{
	 if(sta==3)
	 tmp+=dfs(pos-1,sta,limit&&i==up);
	 else if(i==6)
	 tmp+=dfs(pos-1,sta+1,limit&&i==up);
	 else
	 tmp+=dfs(pos-1,0,limit&&i==up);
	}
	if(!limit) 
	dp[pos][sta]=tmp;
	return tmp; 
}
 
ll solve(ll x)
{
	ll t=x;
    int pos=0;
    while(x)
    {
        a[pos++]=x%10;
        x/=10;
    }
    return dfs(pos-1,0,true);
    
}
int main()
{
	
    memset(dp,-1,sizeof(dp));
    int T;
    cin>>T;
    for(int i=1;i<=T;i++)
    {
	ll n,m;
	scanf("%lld",&n);
	ll l=666,r=1e18,mid;
	while(l<=r)
	{
	
	 mid=(l+r)/2;
	 if(solve(mid)>=n)
	 	r=mid-1;
	 else
	 	l=mid+1;
	 	
	}
	printf("%lld\n",l);
    }

    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值