1010 Radix (25 分)

1010 Radix (25 分)

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is yes, if 6 is a decimal number and 110 is a binary number.

Now for any pair of positive integers N1 and N2, your task is to find the radix of one number while that of the other is given.

Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:

N1 N2 tag radix

Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set { 0-9, a-z } where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number radix is the radix of N1 if tag is 1, or of N2 if tag is 2.

Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print Impossible. If the solution is not unique, output the smallest possible radix.

Sample Input 1:

6 110 1 10



结尾无空行

Sample Output 1:

2



结尾无空行

Sample Input 2:

1 ab 1 2



结尾无空行

Sample Output 2:

Impossible



结尾无空行

Code:

#include <iostream>
#include <cctype>
#include <algorithm>
#include <cmath>
using ll = long long ;
using namespace std;
//convert函数:给定⼀个数值和⼀个进制,将它转化为10进制。转化过程中可能产⽣溢出
//find_radix函数:找到令两个数值相等的进制数。在查找的过程中,需要使⽤⼆分查找算法,如果使⽤
//当前进制转化得到数值⽐另⼀个⼤或者⼩于0,说明这个进制太⼤~
ll convert(string n, ll radix)
{
    ll sum = 0;
    int index = 0, temp = 0;
    for (auto it = n.rbegin(); it != n.rend(); it++)
    {
        temp = isdigit(*it) ? *it - '0' : *it - 'a' + 10;
        sum += temp * pow(radix, index++);
    }
    return sum;
}
ll find_radix(string n, ll num)
{
    char it = *max_element(n.begin(), n.end());//找出字符串最大元素
    ll low = (isdigit(it) ? it - '0' : it - 'a' + 10) + 1;//最大元素加一才能成为可能的最小进制
    ll high = max(num, low);
    while (low <= high)
    {
        ll mid = (low + high) / 2;
        ll t = convert(n, mid);
        if (t < 0 || t > num)//小于0则溢出 大于零则进制过大
            high = mid - 1;
        else if (t == num)
            return mid;
        else
            low = mid + 1;
    }
    return -1;
}
int main()
{
    string n1, n2;
    ll tag = 0, radix = 0, result_radix;
    cin >> n1 >> n2 >> tag >> radix;
    result_radix = tag == 1 ? find_radix(n2, convert(n1, radix)) : find_radix(n1, convert(n2, radix));
    if (result_radix != -1)
    {
        printf("%lld", result_radix);
    }
    else
    {
        printf("Impossible");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

追寻远方的人

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值