1010 Radix (25分)

@[TOC](1010 Radix (25分))

1010 Radix (25分)

题目

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is yes, if 6 is a decimal number and 110 is a binary number.
Now for any pair of positive integers N​1 and N​2​​ , your task is to find the radix of one number while that of the other is given.

Input Specification:
Each input file contains one test case. Each case occupies a line which contains 4 positive integers:N1 N2 tag radix Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set { 0-9, a-z } where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number radix is the radix of N1 if tag is 1, or of N2 if tag is 2.

Output Specification:
For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print Impossible. If the solution is not unique, output the smallest possible radix.

Sample Input 1:
6 110 1 10
Sample Output 1:
2

Sample Input 2:
1 ab 1 2
Sample Output 2:
Impossible

说明

这个题目没说清楚,对于用例0 0 1 10,输出1正确,但是怎么会有1进制。

代码

#include<iostream>
#include<math.h>
#include<string>
using namespace std;

int charToint(char c)
{
	int res = 0;
	if (c >= '0'&&c <= '9')
		res = c - '0';
	else
		res = c - 'a' + 10;
	return res;
}

long long ToDecimalNumber(string number, int radix)
{
	long long res = 0;
	int n = number.size();
	for (int i = 0; i < n; i++)
	{
		res += charToint(number[i])*pow(radix, n - i - 1);
	}
	return res;
}

int isPossible(string number, long long tarNum)
{
	int minRadix = 0;
	long long maxRadix = 0, midRadix;
	for (int i = 0; i < number.size(); i++)
	{
		if (minRadix < charToint(number[i]))
			minRadix = charToint(number[i]);
	}
	minRadix += 1;
	maxRadix = minRadix > tarNum ? minRadix : tarNum;
	while (minRadix<=maxRadix)
	{
		midRadix = (minRadix + maxRadix) / 2;
		long long t = ToDecimalNumber(number, midRadix);
		if (t<0 || t>tarNum)
			maxRadix = midRadix - 1;
		else if (t == tarNum)
			return midRadix;
		else
			minRadix = midRadix + 1;
	}
	return -1;
}

int main()
{
	string number1, number2;
	int flag, radix, res;
	cin >> number1 >> number2 >> flag >> radix;
	res = flag == 1? isPossible(number2, ToDecimalNumber(number1, radix)): isPossible(number1, ToDecimalNumber(number2, radix));
	//if (res < 2)
	//	res = 2;
	if (res != -1)
		cout << res;
	else
		cout << "Impossible";

	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值