1023 Have Fun with Numbers (20 分)

1023 Have Fun with Numbers (20 分)

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.

Sample Input:

1234567899



结尾无空行

Sample Output:

Yes
2469135798结尾无空行

Code:

#include <bits/stdc++.h>
using namespace std;
int main()
{
    int book[10] = {0};
    char ch[22];
    bool flag = true;
    int carry = 0;
    scanf("%s", ch);
    int len = strlen(ch);
    for (int i = len - 1; i >= 0; i--)
    {
        int temp = ch[i] - '0';
        book[temp]++;
        temp = temp * 2 + carry;
        carry = 0;
        if (temp >= 10)
        {
            carry = 1;
            temp -= 10;
        }
        ch[i] = temp + '0';
        book[temp]--;
    }
    for (int i = 0; i < 10; i++)
    {
        if (book[i])
            flag = false;
    }
    if (flag && carry == 0)
        cout << "Yes" << endl;
    else
    {
        cout << "No" << endl;
        if(carry==1)
        printf("1");
    }
    printf("%s", ch);
    return 0;
}

#include <bits/stdc++.h>
using namespace std;
int book[10] = {0};
int main()
{
    string str;
    bool flag = true;
    int carry = 0;
    cin >> str;
    int len = str.length();
    for (int i = len - 1; i >= 0; i--)
    {
        int temp = str[i] - '0';
        book[temp]++;
        temp = temp * 2 + carry;
        carry = 0;
        if (temp >= 10)
        {
            carry = 1;
            temp -= 10;
        }
        str[i] = temp + '0';
        book[temp]--;
    }
    if (carry == 1)
        str.insert(0, "1");
    for (int i = 0; i < 10; i++)
    {
        if (book[i])
            flag = false;
    }
    //carry == 0可以省略 多了一位 flag 必定为false 
    if (flag && carry == 0)
        cout << "Yes" << endl;
    else
    {
        cout << "No" << endl;
    }
    cout << str;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

追寻远方的人

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值