UVa 11427 Expect the Expected

160 篇文章 0 订阅
42 篇文章 0 订阅
Some mathematical background. This problem asks you to compute the expected value of a random
variable. If you haven’t seen those before, the simple definitions are as follows. A random variable is a
variable that can have one of several values, each with a certain probability. The probabilities of each
possible value are positive and add up to one. The expected value of a random variable is simply the
sum of all its possible values, each multiplied by the corresponding probability. (There are some more
complicated, more general definitions, but you won’t need them now.) For example, the value of a fair,
6-sided die is a random variable that has 6 possible values (from 1 to 6), each with a probability of 1/6.
Its expected value is 1/6 + 2/6 + . . . + 6/6 = 3.5. Now the problem.
I like to play solitaire. Each time I play a game, I have probability p of solving it and probability
(1 − p) of failing. The game keeps statistics of all my games – what percentage of games I have won.
If I simply keep playing for a long time, this percentage will always hover somewhere around p ∗ 100%.
But I want more.
Here is my plan. Every day, I will play a game of solitaire. If I win, I’ll go to sleep happy until
the next day. If I lose, I’ll keep playing until the fraction of games I have won today becomes larger
than p. At this point, I’ll declare victory and go to sleep. As you can see, at the end of each day, I’m
guaranteed to always keep my statistics above the expected p ∗ 100%. I will have beaten mathematics!
If your intuition is telling you that something here must break, then you are right. I can’t keep
doing this forever because there is a limit on the number of games I can play in one day. Let’s say that
I can play at most n games in one day. How many days can I expect to be able to continue with my
clever plan before it fails? Note that the answer is always at least 1 because it takes me a whole day
of playing to reach a failure.
Input
The first line of input gives the number of cases, N. N test cases follow. Each one is a line containing
p (as a fraction) and n.
1 ≤ N ≤ 3000, 0 ≤ p < 1,
The denominator of p will be at most 1000,
1 ≤ n ≤ 100.
Output
For each test case, print a line of the form ‘Case #x: y’, where y is the expected number of days,
rounded down to the nearest integer. The answer will always be at most 1000 and will never be within
0.001 of a round-off error case.
Sample Input
4
1/2 1
1/2 2
0/1 10
1/2 3
Sample Output
Case #1: 2
Case #2: 2
Case #3: 1

Case #4: 2

~~~~~~~~~~~~~~~~~~~~~~~~~~~~

期望+DP~

神奇的题目。推荐题解:http://blog.csdn.net/tc_to_top/article/details/47961387


#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

int t,a,b,n,kkz,totcas;
double p,f[105][105],ans;

int main()
{
	scanf("%d",&t);
	while(t--)
	{
		memset(f[kkz],0,sizeof(f[kkz]));
		scanf("%d/%d %d",&a,&b,&n);
		p=(double)a/b;ans=0;
		f[kkz][0]=1;
		for(int i=1;i<=n;i++)
		{
			kkz^=1;
			memset(f[kkz],0,sizeof(f[kkz]));
			f[kkz][0]=f[kkz^1][0]*(1.0-p);
			for(int j=1;j<=i;j++)
			{
				f[kkz][j]+=f[kkz^1][j]*(1.0-p);
				if(j*b<=i*a) f[kkz][j]+=f[kkz^1][j-1]*p;
			}
		}
		for(int i=0;i<=n;i++) ans+=f[kkz][i];
		printf("Case #%d: %d\n",++totcas,(int)(1.0/ans));
	}
	return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值