DP-POJ 1458 (LCS 最长公共子序列)

Common Subsequence
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 48523 Accepted: 19995

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0

Source



题意:

输入两个字符串,找出两个串中出现顺序相同且对应相同的字符个数。例如, Z = < a, b, f, c> is a subsequence of X = < a, b, c, f, b, c > with index sequence< 1, 2, 4, 6 >.一共4个

思路:

LCS类型,最长公共子序列。滚动数组的升级版,设立二维数组ans[i][j]全置为0,横行,纵行分别是两个字符串。从ans[0][0]开始遍历直到比较到两个字符串的最后一个字母。即从矩阵左上角到右下角。

每次均为记忆化搜索,过程:

1、取该位置为左上方位置的值

2、比较给位置的对应的两个字符是否匹配,匹配在原值上加1

3、找出该位置的左相邻元素和右相邻元素的最大值,覆盖原值

4、对每一点进行1到3方式的遍历,更新该矩阵

5、更新完毕后,最后一排最大值即为最终答案(PS:为方便输出,输出结果是矩阵右下角位置的值)

图解(并不准确,有问题,只是“大体”的思路展示)


代码:

#include<iostream>

#include<cstring>

#include<cstdio>

using namespace std;

 

int match(char a,char b){

    return a==b?1:0;

}

 

int max(int a,int b,int c){

    int ans;

    ans=max(max(a,b),c);

    return ans;

}

int main(){

    int l1,l2;

    char a[1000],b[1000];

    int ans[1000][1000];

    while(scanf("%s%s",a,b)!=EOF){

        memset(ans,0,sizeof(ans));   

        l1=strlen(a);

        l2=strlen(b);

        for(inti=1;i<=l1;i++)

            for(intj=1;j<=l2;j++){

                ans[i][j]=max(ans[i-1][j-1]+match(a[i-1],b[j-1]),ans[i-1][j],ans[i][j-1]);//DP核心

            }

        cout<<ans[l1][l2]<<endl;

    }

    return 0;

}

 



革命尚未成功!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值