ZOJ#3210:A Stack or A Queue?

Memory Limit: 32768KB
64bit IO Format: %lld & %llu

Description

Do you know stack and queue? They’re both important data structures. A stack is a “first in last out” (FILO) data structure and a queue is a “first in first out” (FIFO) one.

Here comes the problem: given the order of some integers (it is assumed that the stack and queue are both for integers) going into the structure and coming out of it, please guess what kind of data structure it could be - stack or queue?

Notice that here we assume that none of the integers are popped out before all the integers are pushed into the structure.

Input

There are multiple test cases. The first line of input contains an integer T (T <= 100), indicating the number of test cases. Then T test cases follow.

Each test case contains 3 lines: The first line of each test case contains only one integer N indicating the number of integers (1 <= N <= 100). The second line of each test case contains N integers separated by a space, which are given in the order of going into the structure (that is, the first one is the earliest going in). The third line of each test case also contains N integers separated by a space, whick are given in the order of coming out of the structure (the first one is the earliest coming out).

Output

For each test case, output your guess in a single line. If the structure can only be a stack, output “stack”; or if the structure can only be a queue, output “queue”; otherwise if the structure can be either a stack or a queue, output “both”, or else otherwise output “neither”.

Sample Input

4
3
1 2 3
3 2 1
3
1 2 3
1 2 3
3
1 2 1
1 2 1
3
1 2 3
2 3 1

Sample Output

stack
queue
both
neither

Source
The 6th Zhejiang Provincial Collegiate Programming Contest

AC代码如下:

#include<iostream>
using namespace std;
int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        int a[100],b[100],q=0,t=0,n;
        cin>>n;
        for(int i=0;i<n;i++)
            cin>>a[i];
        for(int i=0;i<n;i++)
            cin>>b[i];
        for(int i=0;i<n;i++)
        {
            if(a[i]==b[i])
                q++;
            else continue;
        }
        for(int i=n-1,j=0;i>=0,j<n;i--,j++)
        {
            if(a[i]==b[j])
                t++;
            else continue;
        }
        if(q==n&&t==n) cout<<"both"<<endl;
        else if(q==n&&t<=n-2) cout<<"queue"<<endl;
        else if(q<=n-2&&t==n) cout<<"stack"<<endl;
        else cout<<"neither"<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值