win32系统 python3.4 安装matplotlib

前言:这两天用到Python的matplotlib模块,安装书上的介绍,先后装了numpy,scipy,matplotlib模块,但是也出现各种问题,现在回想下,其实准备得当,一条龙下来很快地,下面我总结下,希望能帮还在纠结matplotlib安装的朋友少走点弯路。

系统:WIN32

Python版本:3.4

准备资料:

1、numpy

        2、scipy

        3、six

        4、dateutil

        5、pyparsing

        6、matplotlib

   只要下载好上面模块对应的版本,依次安装就可搞定。

模块文件下载路径:

       http://download.csdn.net/detail/shadow_dreamer/8755717

备注:

      安装scipy后可以去python3.4\Lib\site-packages\scipy\_lib\文件夹下拷six.py到python3.4\Lib\site-packages\下,这样可以省去安装six模块那一步(如果拷贝后加载报“需要six1.3版本,你只有1.2版本”错误的话,你还要自己下载更高版本安装的)。

       

发布了7 篇原创文章 · 获赞 7 · 访问量 2万+
展开阅读全文

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 大白 设计师: CSDN官方博客

分享到微信朋友圈

×

扫一扫,手机浏览