hdu——1358Period(kmp专练)

Period

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5845    Accepted Submission(s): 2835


Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
 

Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
 

Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
 

Sample Input
  
  
3 aaa 12 aabaabaabaab 0
 

Sample Output
  
  
Test case #1 2 2 3 3 Test case #2 2 2 6 2 9 3 12 4
 

Recommend
JGShining

kmp的扩展运用
#include<iostream>
#include<string>
#include<cstring>
#include<algorithm>
using namespace std;
int nexta[1000111];
void getnext(string s)
{
	int i=0,j=-1;
	nexta[0]=-1;
	while(i<s.size())
	{
		if(s[i]==s[j]||j==-1)
		{
			++i;
			++j;
			nexta[i]=j;
		}
		else j=nexta[j];
	}
}
int main()
{
	long long k,n,m,i,jj;
	char a[10010];
	string s;
	ios::sync_with_stdio(false);
	jj=1;
	while(cin>>k&&k!=0)
	{
		cin>>s;
		getnext(s);
		cout<<"Test case #"<<jj<<endl;
		for(i=2;i<=k;i++)
		{
			n=i-nexta[i];
			if(i%n==0&&i/n>1)//看是否循环
			{
			cout<<i<<" "<<i/n<<endl;
			}
		}<pre name="code" class="cpp"><span style="white-space:pre">		</span>//找出重复次数大于1时的位置 并且输出重复次数
++jj;cout<<endl;}return 0;}/*一个字符串,问从头到某个位置,字符串的前缀最多重复了多少次。比方aaaa的字符串,到第二个字符,前缀a重复了两次,到第三个字符,前缀a重复了三次,到第四个字符,前缀a重复了四次,前缀aa重复了两次,但我们要得到的是重复了四次。*/
 
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值