hdu-1241Oil Deposits(dfs 找出不同的区块)

Oil Deposits

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 
 

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
 

Sample Input
  
  
1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
 

Sample Output
  
  
0 1 2 2
 

Source
 

Recommend
Eddy   |   We have carefully selected several similar problems for you:  1312 1242 1240 1181 1372 

将地图中给出的每个@都进行dfs 将八个发现的同一个区块中的@变成.  然后计算进行了几次dfs  就相当于有几个区块  我的代码是另外一种方法  保留dfs第一个@清除同一个区块的@剩下的就是代表有几个区块

#include<iostream>
#include<string>
#include<cstring>
using namespace std;
char land[105][105];
int n,m,i,j,res;
bool vis[105][105]={
    0
};
int dx[]={-1,-1,-1,0,0,1,1,1};
int dy[]={-1,0,1,1,-1,-1,0,1};
bool dfs(int x,int y)
{
    if(vis[x][y]||land[x][y]=='*')
    return false;
    vis[x][y]=1;
    int ai,aj;
    for(int k=0;k<8;k++)
    {
    ai=x+dx[k];
    aj=y+dy[k];
    if(ai>=0&&aj>=0&&ai<m&&aj<n)
    {
        if(dfs(ai,aj))
        res--;
    }    
    }
    return true;
}
int main()
{
    while(cin>>m>>n,m)
    {
        res=0;
        memset(vis,0,sizeof(vis));
        for(i=0;i<m;i++)
        {
            for(j=0;j<n;j++)
            {
                cin>>land[i][j];
                if(land[i][j]=='@')
                res++;
            }
        }
        for(i=0;i<m;i++)
        {
            for(j=0;j<n;j++)
            {
                if(!vis[i][j])
                dfs(i,j);
            }
        }
        cout<<res<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值