Prime Ring Problem hdu 1016

Prime Ring Problem

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 17   Accepted Submission(s) : 13
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


Input

n (0 < n < 20).

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

Source

Asia 1996, Shanghai (Mainland China)


素数环

   #include <iostream>  
    #include <cstring>  
    using namespace std;  
    int n,visited[30],buffer[30],ans,flag;  
    bool is_prime(int x,int y)  
    {  
        int sum=x+y;  
        for(int i=2;i*i<=sum;i++)  
        {  
            if(sum%i==0)  
                return 0;  
        }  
        return 1;  
    }  
      
    void dfs(int cur)  
    {  
        visited[1]=1;  
        if(cur>n && is_prime(buffer[1],buffer[n]))  
        {  
      
            if(!flag)  
            {  
                printf("Case %d:\n",ans);  
                flag=1;  
            }  
            for(int i=1;i<n;i++)  
            {  
                printf("%d ",buffer[i]);  
            }  
            printf("%d\n",buffer[n]);  
      
        }  
        else  
        {  
            for(int i=2;i<=n;i++)  
            {  
                buffer[cur]=i;  
                if(!visited[i] && is_prime(buffer[cur-1],buffer[cur]))  
                {  
                    visited[i]=1;  
                    dfs(cur+1);  
                    visited[i]=0;  
                }  
            }  
        }  
    }  
      
    int main()  
    {  
        ans=0;  
        while(scanf("%d",&n)!=EOF)  
        {  
            ans++;  
            flag=0;  
            memset(visited,0,sizeof(visited));  
            buffer[1]=1;  
            dfs(2);  
            printf("\n");  
        }  
        return 0;  
    } 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值