HDU 1250 Hat's Fibonacci

Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.
 

Input
Each line will contain an integers. Process to end of file.
 

Output
For each case, output the result in a line.
 

Sample Input
  
  
100
 

Sample Output
  
  
4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.

 题意:斐波那契数列的变形,原来的斐波那契是f(n)=f(n-1)+f(n-2),现在变成了f(n)=f(n-1)+f(n-2)+f(n-3)+f(n-4);而且限制了长度最大为2500,这样直接开二维数组f[10000][2500]肯定就过不去了,转化一下,用一个数组存五个位,2500/5=500,这样开二维数组 f[10000][510]就不会内存超限了,还能节约时间。

#include<stdio.h>
#include<string.h>
int fib[10010][510];
int main()
{
    int i,j,n,m;
    fib[1][0]=fib[2][0]=fib[3][0]=fib[4][0]=1;
    int dig=1;
    for(i=5; i<10000; i++)
    {
        int c=0;//进位
        for(j=0; j<=510; j++)
        {
            fib[i][j]=fib[i-1][j]+fib[i-2][j]+fib[i-3][j]+fib[i-4][j]+c;
            c=fib[i][j]/100000;
            fib[i][j]=fib[i][j]%100000;

        }
    }
    while(~scanf("%d",&n))
    {
        for(i=501; i>=0; i--)
            if(fib[n][i]) break;
        printf("%d",fib[n][i]);//第一个直接输出
        for(j=i-1; j>=0; j--)
            printf("%05d",fib[n][j]);//每个存五位
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值