PTA-数据结构-05-树8 File Transfer (25 分) && 为什么 传参数要用const vector<int> &而不是 vector<int>

We have a network of computers and a list of bi-directional connections. Each of these connections allows a file transfer from one computer to another. Is it possible to send a file from any computer on the network to any other?

Input Specification:
Each input file contains one test case. For each test case, the first line contains N (2≤N≤10
​4
​​ ), the total number of computers in a network. Each computer in the network is then represented by a positive integer between 1 and N. Then in the following lines, the input is given in the format:

I c1 c2
where I stands for inputting a connection between c1 and c2; or

C c1 c2
where C stands for checking if it is possible to transfer files between c1 and c2; or

S
where S stands for stopping this case.

Output Specification:
For each C case, print in one line the word “yes” or “no” if it is possible or impossible to transfer files between c1 and c2, respectively. At the end of each case, print in one line “The network is connected.” if there is a path between any pair of computers; or “There are k components.” where k is the number of connected components in this network.

Sample Input 1:
5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
S
Sample Output 1:
no
no
yes
There are 2 components.
Sample Input 2:
5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
I 1 3
C 1 5
S
Sample Output 2:
no
no
yes
yes
The network is connected.

#include <iostream>
#include <vector>
#include <string>

using namespace std;

/* 这里如果用vector<int> cs传递参数,用PTA的大测试数据会报运行超时,用const vector<int>&就没有问题
 * 用vector<int> 传递参数,每次函数被调用的时候,会构造一个新的vector<int> 对象,并且把实参里面的
 * 数据hard copy过来,这两个操作都需要消耗时间,所以PTA大测试数据会报运行超时。
 * 如果用const vector<int>& cs, 则只是传递一个引用过来,耗时很短。
 * 类似c语言中,在传递大参数的时候需要压栈,也是要消耗cpu cycle的。
 */
int findRoot(const vector<int>& cs, int c)
{
    /* 路径压缩
	if (cs[c] < 0)
        return c;
    else
        return cs[c] = findRoot(cs ,cs[c]);
        */
    while(1)
    {
        if (cs[c] < 0)
            break;
        c = cs[c];
    }

    return c;
}


bool check(const vector<int>& cs, int c1, int c2)
{
	return findRoot(cs, c1) == findRoot(cs, c2);
}

void connect(vector<int>  & cs, int c1, int c2)
{
	c1 = findRoot(cs, c1);
	c2 = findRoot(cs ,c2);
	
	if (cs[c2] < cs[c1])
	{
        cs[c2] = cs[c2] + cs[c1];
		cs[c1] = c2;
	}
	else
	{
		cs[c1] = cs[c1] + cs[c2];
		cs[c2] = c1;
	}
}



int main(void)
{
	int n;
	
	cin >> n;
	
	vector<int> connections;
	vector<string> results;
	
	for (int i=0;i<=n;i++)
		connections.push_back(-1);
		
	while(1)
	{
		char cmd;
		int c1, c2;
		cin >> cmd;
		
		if (cmd == 'S')
			break;
		
		cin >> c1 >> c2;
		
		if (cmd == 'C')
		{
			if (check(connections, c1, c2))
				results.push_back("yes");
			else
				results.push_back("no");
		}
		else if (cmd == 'I')
		{
			connect(connections, c1, c2);
		}
	}
	
	int parts = 0;
	for (int i=1;i<connections.size();i++)
	{
		if (connections[i] < 0)
			parts ++;
	}
	
	
	for (int i=0;i<results.size();i++)
		cout << results[i] << endl;
	
	if (parts == 1)
		cout << "The network is connected.";
	else
		cout << "There are " << parts << " components.";
	
	return 0; 
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值