1003 Emergency

1003 Emergency (25 分)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C​1 and C​2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2
​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C​1​​ to C2​​ .

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C​1 and C​2​ , and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

Answer

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.Arrays;
import java.util.StringTokenizer;

public class Main {

  int N, M, C1, C2;
  MGraph graph;
  int[] shortestPathCnt;
  int[] yield;

  public void input() {
    N = Console.nextInt();
    M = Console.nextInt();
    C1 = Console.nextInt();
    C2 = Console.nextInt();
    graph = new MGraph(N, M);
    for (int i = 0; i < N; i++) {
      graph.vertexArr[i].value = Console.nextInt();
    }
    for (int i = 0; i < N; i++) {
      Arrays.fill(graph.edges[i], graph.INF);
    }
    for (int i = 0; i < M; i++) {
      int a = Console.nextInt();
      int b = Console.nextInt();
      graph.edges[a][b] = graph.edges[b][a] = Console.nextInt();
    }
  }

  public void process() {
    shortestPathCnt = new int[graph.n];
    yield = new int[graph.n];
    dijkstra();
    System.out.print(shortestPathCnt[C2] + " " + yield[C2]);
  }

  public void dijkstra() {
    int[] distance = new int[graph.n];
    Arrays.fill(distance, graph.INF);
    int v = C1;
    boolean[] visited = new boolean[graph.n];
    distance[v] = 0;
    shortestPathCnt[v] = 1;
    yield[v] = graph.vertexArr[v].value;

    for (int i = 0; i < graph.n; i++) {
      int u = -1;
      int min = graph.INF;
      for (int j = 0; j < graph.n; j++) {
        if (!visited[j] && distance[j] < min) {
          u = j;
          min = distance[j];
        }
      }
      visited[u] = true;
      //以刚并入的顶点作为中间点,对其余各顶点进行检测
      for (int j = 0; j < graph.n; j++) {
        if(!visited[j]){
          int tmpDist = distance[u] + graph.edges[u][j];
          if (tmpDist < distance[j]) {
            distance[j] = tmpDist;
            shortestPathCnt[j] = shortestPathCnt[u];
            yield[j] = yield[u] + graph.vertexArr[j].value;
          } else if (tmpDist == distance[j] && distance[u] != 0) {
            shortestPathCnt[j] += shortestPathCnt[u];
            if (yield[u] + graph.vertexArr[j].value > yield[j]) {
              yield[j] = yield[u] + graph.vertexArr[j].value;
            }
          }
        }
      }
    }
  }

  static class MGraph {

    int n;  //顶点个数
    int e;   //边个数
    int[][] edges;  //邻接矩阵
    Vertex[] vertexArr; //顶点数组
    public static final int INF = 9999;

    public MGraph() {
    }

    public MGraph(int n, int e) {
      this.n = n;
      this.e = e;
      this.edges = new int[n][n];
      this.vertexArr = new Vertex[n];
      for (int i = 0; i < n; i++) {
        this.vertexArr[i] = new Vertex(i);
      }
    }
  }

  /**
   * 顶点类型定义
   */
  static class Vertex {

    int no; //编号
    int value; //顶点值

    public Vertex(int no) {
      this.no = no;
    }

    public Vertex(int no, int info) {
      this.no = no;
      this.value = info;
    }
  }

  public static void main(String[] args) {
    new Main().run();
  }

  public void run() {
    input();
    process();
  }

  static class Console {

    private final BufferedReader bf;
    private StringTokenizer tokenizer;
    private static final Console instance;

    static {
      instance = new Console();
    }

    public Console() {
      bf = new BufferedReader(new InputStreamReader(System.in));
    }

    public static String nextLine() {
      try {
        return instance.bf.readLine();
      } catch (IOException e) {
        e.printStackTrace();
        return null;
      }
    }

    public static StringTokenizer nextTokenizer() {
      return new StringTokenizer(nextLine());
    }

    public static String next() {
      if (instance.tokenizer == null || !instance.tokenizer.hasMoreTokens()) {
        instance.tokenizer = nextTokenizer();
      }
      return instance.tokenizer.nextToken();
    }

    public static int nextInt() {
      return Integer.parseInt(next());
    }

    public static long nextLong() {
      return Long.parseLong(next());
    }

    public static double nextDouble() {
      return Double.parseDouble(next());
    }

  }
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

IT研究僧大师兄

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值