HDU 4715 Difference Between Primes

Description
All you know Goldbach conjecture.That is to say, Every even integer greater than 2 can be expressed as the sum of two primes. Today, skywind present a new conjecture: every even integer can be expressed as the difference of two primes. To validate this conjecture, you are asked to write a program. 
Input
The first line of input is a number nidentified the count of test cases(n<10^5). There is a even number xat the next nlines. The absolute value of xis not greater than 10^6. 
Output
For each number xtested, outputstwo primes aand bat one line separatedwith one space where a-b=x. If more than one group can meet it, output the minimum group. If no primes can satisfy it, output 'FAIL'. 
Sample Input
3
6
10
20
Sample Output
11 5
13 3
23 3
题意:把一个偶数分解成两个素数之差,输出最小的两个素数
思路:用埃氏筛法打个素数表,然后从最小的素数枚举就好.

AC代码:

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<algorithm>
using namespace std;
const int pmax=1e5+10;
const int vmax=1e6+10;
int prime[pmax],vis[vmax],psize=0;
void getprime()
{
    memset(vis,0,sizeof vis);
    vis[0]=vis[1]=1;
    for(int i=2;i<sqrt(vmax+0.5);i++) if(!vis[i])
        for(int j=i*i;j<vmax;j+=i)
            vis[j]=1;
    for(int i=2;i<vmax;i++)
        if(!vis[i])
            prime[psize++]=i;
}

int main()
{
    getprime();
    int n;
    scanf("%d",&n);
    while(n--)
    {
        int x,a,b;
        scanf("%d",&x);
        for(int i=0;;i++)
        {
            if(!vis[(prime[i]+abs(x))])
            {
                a=prime[i];
                b=abs(x)+prime[i];
                break;
            }
        }
        if(x>0)
            swap(a,b);
        cout<<a<<' '<<b<<endl;
    }
    return 0;
}

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值