poj1519 数论简单题

Digital Roots
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 26535 Accepted: 8874

Description

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit. 

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

Input

The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

Output

For each integer in the input, output its digital root on a separate line of the output.

Sample Input

24
39
0

Sample Output

6
3

这道题要求求一个数的“树根”。先求一个数每位数字之和,如果和不为一个个位数,则将该数再求位数和,直到位数和为个位数,这个个位数就是该数的“树根”。

开始做的时候用的是递归写的,结果超时了。正确解这题的做法是将该数字每位数字之和再mod 9。这就行了。

树根=位数和(mod 9)

代码:

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
char str[100];
int main()
{
    
    while(scanf("%s",str))
    {
        if(str[0]=='0')
            break;
        int sum=0;
        int len=strlen(str);
        for(int i=0;i<len;i++)
        {
            sum+=str[i]-'0';
        }
        sum=sum%9;
        if(!sum)
            sum=9;
        printf("%d\n",sum);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值