acm之贪心算法题目10

这篇博客介绍了如何使用贪心算法来解决一个ACM竞赛中的问题。FatMouse试图用猫粮交换仓库里的JavaBean,每个房间的JavaBean数量和所需的猫粮量不同。问题要求计算出FatMouse能获得的最大JavaBean量。输入包含多个测试用例,每个用例有猫粮总量M和房间数N,以及每个房间的JavaBean和猫粮需求。输出是FatMouse能获取的最大JavaBean量,保留小数点后三位。样例输入和输出展示了具体计算过程。
摘要由CSDN通过智能技术生成

Problem Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1’s. All integers are not greater than 1000.

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

Sample Output

13.333
31.500

代码:

#include<stdio.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;

#define Max 1000

struct room{
    double j,f;
    double rate;
}Room[Max];

bool cmp(room a,room b)
{
    return a.rate>b.rate;
}


int main()
{
    int N; 
    double M,sumJ;
    int i;
    while(scanf("%lf %d",&M,&N))
    {
        if(M==-1&&N==-1)
            break;
        for(i=0;i<N;i++)
        {
            scanf("%lf%lf",&Room[i].j,&Room[i].f);
            Room[i].rate=(double)Room[i].j/Room[i].f;
        }
        sort(Room,Room+N,cmp); 
        sumJ=0;
        for(i=0;i<N;i++)
        {
            if(M>=Room[i].f)
            {
                sumJ+=Room[i].j;
                M-=Room[i].f;
            }
            else
            {
                sumJ+=(Room[i].rate)*M;
                break;
            }
        }
        printf("%.3lf\n",sumJ);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值