20-2-12-差分约束系统的建立和求解-POJ1201

POJ1201

Intervals

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 33864Accepted: 13036

Description

You are given n closed, integer intervals [ai, bi] and n integers c1, …, cn.
Write a program that:
reads the number of intervals, their end points and integers c1, …, cn from the standard input,
computes the minimal size of a set Z of integers which has at least ci common elements with interval [ai, bi], for each i=1,2,…,n,
writes the answer to the standard output.

Input

The first line of the input contains an integer n (1 <= n <= 50000) – the number of intervals. The following n lines describe the intervals. The (i+1)-th line of the input contains three integers ai, bi and ci separated by single spaces and such that 0 <= ai <= bi <= 50000 and 1 <= ci <= bi - ai+1.

Output

The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai, bi], for each i=1,2,…,n.

Sample Input

5
3 7 3
8 10 3
6 8 1
1 3 1
10 11 1

Sample Output

6

Source

Southwestern Europe 2002

#pragma warning(disable:4996)
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<queue>
using namespace std;
const int INF = 0x3f3f3f3f;
const int maxn = 50005;
int head[maxn];
bool vis[maxn];
int d[maxn];
struct Edge {
	int v, cost;
	int next;
	Edge(int v_ = 0, int cost_ = 0, int next_ = 0) {
		v = v_;
		cost = cost_;
		next = next_;
	}
	void setNext(int next_) {
		next = next_;
	}
};
Edge edge[maxn * 10];
int num_edge = 0;

void addEdge(int u, int v, int cost) {
	edge[num_edge] = Edge(v, cost, head[u]);
	head[u] = num_edge++;
}


int spfa(int minn, int maxx) {
	//[0,minn]的区间内的所有的数初始化为0
		//来考虑minn这个位置是否需要初始化为-1
		//题目所求为d[maxx+1]-d[minn], 故d[minn]=0
		//(minn,maxx]内的所有的数初始化为-1
	fill(d + minn + 1, d + maxx + 1, -1);
	vis[minn] = true;
	queue<int>q;
	q.push(minn);
	while (!q.empty()) {
		int top = q.front();
		q.pop();
		vis[top] = false;
		for (int i = head[top]; i != -1; i = edge[i].next) {
			int v = edge[i].v;
			if (d[v] < d[top] + edge[i].cost) {
				d[v] = d[top] + edge[i].cost;
				if (!vis[v]) {
					vis[v] = true;
					q.push(v);
				}
			}
		}
	}
	return d[maxx + 1];
}

//设d[i]代表从[0,i]的区间内至少选出d[i]个数
	//对于每一个[ai,bi],都有d[bi]-d[ai-1]>=ci
	//一个隐含的条件0<=d[i]-d[i-1]<=1
	//其中0<=ai<=bi<=50000
//ai==0时, 上述的d[ai-1]产生了d[-1], d[i-1]产生了d[-1]
	//为了解决这个问题, 将d[i+1]表示为[0,i]选出的d[i+1]个数
	//这样当i==0时, [0,0]选出的d[1]个数便可以表示了
	//此时建立约束图时, 边为(ai,bi+1)
int main() {
	int n;
	scanf("%d", &n);
	memset(head, 0xff, sizeof(head));
	int u, v, cost;
	int maxx = 0, minn = INF;
	for (int i = 0; i < n; i++) {
		scanf("%d%d%d", &u, &v, &cost);
		addEdge(u, v + 1, cost);
		maxx = max(maxx, v);
		minn = min(minn, u);
	}
	for (int i = minn; i <= maxx; i++) {
		addEdge(i, i + 1, 0);//隐藏条件d[i]-d[i-1]>=0
		addEdge(i + 1, i, -1); //隐含条件d[i]-d[i-1]<=1
	}
	cout << spfa(minn, maxx) << "\n";
	return 0;
}

/*
5
3 7 3
8 10 3
6 8 1
1 3 1
10 11 1
*/

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值