04-树6 Complete Binary Search Tree (30分)(数据结构)(C语言实现)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

题目是要求输入数的元素个数让你建造一颗完全二叉搜索树.
我们先给出定义以及要实现的函数:

#include<stdio.h>
#include<stdlib.h>
#include<math.h>
#define Max 1050
int num[Max];
int NewTree[Max];
void creatTree(int left,int right,int root);
int getlength(int Treenumber);

主函数实现:

int main()
{
	int i,j=0,t,s;
	int N;
	scanf("%d",&N);
	for(i = 0;i<N;i++)
		{
            scanf("%d",&t);
            num[j++]=t;
        }
	for(i=0;i<j-1;i++)//对数组里的元素按照从小到大排列
	{//我这里采用的冒泡,大家也还可以用别的排序方法
		for(s=i+1;s<j;s++)
		{
			if(num[i]>num[s])
			{
				t=num[s];
				num[s]=num[i];
				num[i]=t;
			}
		}
	}
	creatTree(0,N-1,0);//创造树
    for(i=0;i<N;i++)
    {
        if(i<N-1)
        printf("%d ",NewTree[i]);
        else
        printf("%d",NewTree[i]);
    }
    return 0;

}

建树的函数如下:

void creatTree(int left,int right,int root)
{
	int n=right-left+1;
	if(n==0)return;
	int l=getlength(n);//获得有n个元素的数的左子树元素个数
	NewTree[root]=num[left+l];
	int leftroot=root*2+1;
	int rightroot=leftroot+1;
	creatTree(left,left+l-1,leftroot);
	creatTree(left+l+1,right,rightroot);

}
int getlength(int Treenumber)//这个函数需要大家的好好理解
{
	int i=0,value,left,temp;
	int current;
	for(i=1;i<=Treenumber;i++)
	{
		value=pow(2,i)-1;//第几层一共的结点数
		if(value>=Treenumber)//执行到最后一层了
		{
			break;
		}
	}
		if(value==Treenumber)//恰好是满二叉树
		{
			left=(value-1)/2;//左子树有几个元素
		}
		else//最后一层元素个数不为满
		{
			temp=(pow(2,i-1)-2)/2;//除了最后一层,左子树元素的个数
			current=Treenumber-pow(2,i-1)+1;//最后一层元素的个数
			if(current<=pow(2,i-1)/2)//最后一层左子树元素不满或者恰好相等
				left=current+temp;
			else//最后一层元素左右子树都有
				left=temp+pow(2,i-1)/2;
		}
		return left;
}

题目总代码如下:

#include<stdio.h>
#include<stdlib.h>
#include<math.h>
#define Max 1050
int num[Max];
int NewTree[Max];
void creatTree(int left,int right,int root);
int getlength(int Treenumber);
int main()
{
	int i,j=0,t,s;
	int N;
	scanf("%d",&N);
	for(i = 0;i<N;i++)
		{
            scanf("%d",&t);
            num[j++]=t;
        }
	for(i=0;i<j-1;i++)
	{
		for(s=i+1;s<j;s++)
		{
			if(num[i]>num[s])
			{
				t=num[s];
				num[s]=num[i];
				num[i]=t;
			}
		}
	}
	creatTree(0,N-1,0);
    for(i=0;i<N;i++)
    {
        if(i<N-1)
        printf("%d ",NewTree[i]);
        else
        printf("%d",NewTree[i]);
    }
    return 0;

}
void creatTree(int left,int right,int root)
{
	int n=right-left+1;
	if(n==0)return;
	int l=getlength(n);
	NewTree[root]=num[left+l];
	int leftroot=root*2+1;
	int rightroot=leftroot+1;
	creatTree(left,left+l-1,leftroot);
	creatTree(left+l+1,right,rightroot);

}
int getlength(int Treenumber)
{
	int i=0,value,left,temp;
	int current;
	for(i=1;i<=Treenumber;i++)
	{
		value=pow(2,i)-1;
		if(value>=Treenumber)
		{
			break;
		}
	}
		if(value==Treenumber)
		{
			left=(value-1)/2;
		}
		else
		{
			temp=(pow(2,i-1)-2)/2;
			current=Treenumber-pow(2,i-1)+1;
			if(current<=pow(2,i-1)/2)
				left=current+temp;
			else
				left=temp+pow(2,i-1)/2;
		}
		return left;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值