1064. Complete Binary Search Tree (30)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:
10
1 2 3 4 5 6 7 8 9 0
Sample Output:
6 3 8 1 5 7 9 0 2 4
 
#include <iostream>
#include <vector>
#include <map>
#include <queue>
#include <algorithm>
#include <cstdio>
#include <cstdlib>
using namespace std;
int getroot(int a,int b)
{
	if(a == b)
		return a;
	int level(0);
	int nodenum = b - a + 1;
	while(nodenum != 0)
	{
		nodenum >>= 1;
		++ level;
	}
	nodenum = b - a + 1;
	int remain = nodenum - ((1 << (level - 1)) - 1);
	int destidx;
	if(remain > (1 << (level - 2))) 
	{
		int delta = (1 << (level - 2)) - (remain - (1 << (level - 2)));
		destidx = (nodenum - delta) / 2 + delta;
	}
	else
	{
		destidx = (nodenum - remain) / 2 + remain;
	}
	return a + destidx;
}
int main()
{
	int n;
	cin >> n;
	vector<int> v;
	for(int i = 0;i < n;++ i)
	{
		int tmp;
		cin >> tmp;
		v.push_back(tmp);
	}
	sort(v.begin(),v.end());
	queue<pair<int,int> > qu;
	qu.push(make_pair(0,v.size() - 1));
	vector<int> res;
	while(!qu.empty())
	{
		pair<int,int> elem = qu.front();
		qu.pop();
		int root = getroot(elem.first,elem.second);
		res.push_back(v[root]);
		if(elem.first < elem.second)
		{
			if (elem.first <= root - 1)
				qu.push(make_pair(elem.first,root - 1));
			if (root + 1 <= elem.second)
				qu.push(make_pair(root + 1,elem.second));
		}
	}
	for(int i = 0;i < res.size() - 1;++ i)
		cout << res[i] << " ";
	cout << res[res.size() - 1];
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值