Tree Traversals

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2

Solution:

#include<iostream>
#include<vector>
#include<queue>
#include<fstream>
using namespace std;
struct Node
{
	int num;
	Node* left;
	Node* right;
};
Node* get_tree(vector<int>& post_seq,vector<int>& in_seq,int b1,int e1,int b2,int e2)
{
	if(b1 > e1 || b2 > e2)
		return NULL;
	else
	{
		Node* n = new Node();
		n->num = post_seq[e1];
		int index;
		for(int i = b2;i <= e2; ++ i)
		{
			if(n->num == in_seq[i])
			{
				index = i;
				break;
			}
		}
		n->left = get_tree(post_seq,in_seq,b1,b1 + index - b2 - 1,b2,index - 1);
		n->right = get_tree(post_seq,in_seq,b1 + index - b2,e1 - 1,index + 1,e2);
		return n;
	}
}
void level_travel(Node* r,vector<int>& lev_seq)
{
	queue<Node*> tmp;
	tmp.push(r);
	while(!tmp.empty())
	{
		Node* n = tmp.front();
		lev_seq.push_back(n->num);
		if(n->left != NULL)
			tmp.push(n->left);
		if(n->right != NULL)
			tmp.push(n->right);
		delete n;
		tmp.pop();
	}
}
int main()
{
	int n;
	cin >> n;
	vector<int> post_seq,in_seq,lev_seq;
	for(int i = 0;i < n;++ i)
	{
		int t;
		cin >> t;
		post_seq.push_back(t);
	}	
	for(int i = 0;i < n;++ i)
	{
		int t;
		cin >> t;
		in_seq.push_back(t);
	}	
	Node* root = get_tree(post_seq,in_seq,0,post_seq.size() - 1,0,in_seq.size() - 1);
	level_travel(root,lev_seq);	
	vector<int>::iterator it;
	for(it = lev_seq.begin();it != lev_seq.end();++ it)
	{
		cout << *it;
		if(it != (lev_seq.end() - 1))
			cout << " ";
	}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值