Hdoj 3697 Selecting courses 【贪心】

Selecting courses

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 62768/32768 K (Java/Others)
Total Submission(s): 2082    Accepted Submission(s): 543


Problem Description
    A new Semester is coming and students are troubling for selecting courses. Students select their course on the web course system. There are n courses, the ith course is available during the time interval (A i,B i). That means, if you want to select the ith course, you must select it after time Ai and before time Bi. Ai and Bi are all in minutes. A student can only try to select a course every 5 minutes, but he can start trying at any time, and try as many times as he wants. For example, if you start trying to select courses at 5 minutes 21 seconds, then you can make other tries at 10 minutes 21 seconds, 15 minutes 21 seconds,20 minutes 21 seconds… and so on. A student can’t select more than one course at the same time. It may happen that no course is available when a student is making a try to select a course 

You are to find the maximum number of courses that a student can select.

 

Input
There are no more than 100 test cases.

The first line of each test case contains an integer N. N is the number of courses (0<N<=300)

Then N lines follows. Each line contains two integers Ai and Bi (0<=A i<B i<=1000), meaning that the ith course is available during the time interval (Ai,Bi).

The input ends by N = 0.

 

Output
For each test case output a line containing an integer indicating the maximum number of courses that a student can select.
 

Sample Input
  
  
2 1 10 4 5 0
 

Sample Output
  
  
2

题意:有n门课,选课时有下面rule:

1:每种课都有起始和结束,必须在之内选取。

2:每次选取之后5分钟后不能再选课。

先按照结束时间从小到大排序,因为是每过五分钟才可以选,那么我们只需要枚举前四个时间,看是否在课程的起始与结束时间之内,就可以了。

代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
const int M = 1100;
using namespace std;

struct node{
	int l, r;
}s[M];
int n;
bool vis[M];

bool cmp(node a, node b){
	return a.r < b.r;
}

int f(double x){
	memset(vis, 0, sizeof(vis));
	int res = 0;
	for(double d = x; d < M; d += 5){
		for(int i = 0; i < n; ++ i){
			if(!vis[i]&&d > s[i].l &&s[i].r > d){
				res++;
				vis[i] = 1; break;
			}
		}
	}
	return res;
}

int main(){
	while(scanf("%d", &n), n){
		for(int i = 0; i < n; ++ i) scanf("%d%d", &s[i].l, &s[i].r);
		sort(s, s+n, cmp);
		int ans = 0;
		for(double i = 0.5; i < 5; ++ i){
			ans = max(ans, f(i));
		}
		printf("%d\n", ans);
	}
	return 0;
} 


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值