Live Archive 3177 3177 - Beijing Guards 【枚举】

3177 - Beijing Guards
Time limit: 3.000 seconds
Beijing was once surrounded by four rings of city walls: the Forbidden City Wall, the Imperial City Wall, the Inner City Wall, and finally the Outer City Wall. Most of these walls were demolished in the 50s and 60s to make way for roads. The walls were protected by guard towers, and there was a guard living in each tower. The wall can be considered to be a large ring, where every guard tower has exaetly two neighbors.

The guard had to keep an eye on his section of the wall all day, so he had to stay in the tower. This is a very boring job, thus it is important to keep the guards motivated. The best way to motivate a guard is to give him lots of awards. There are several different types of awards that can be given: the Distinguished Service Award, the Nicest Uniform Award, the Master Guard Award, the Superior Eyesight Award, etc. The Central Department of City Guards determined how many awards have to be given to each of the guards. An award can be given to more than one guard. However, you have to pay attention to one thing: you should not give the same award to two neighbors, since a guard cannot be proud of his award if his neighbor already has this award. The task is to write a program that determines how many different types of awards are required to keep all the guards motivated.

Input

The input contains several blocks of test eases. Each case begins with a line containing a single integer l n 100000, the number of guard towers. The next n lines correspond to the n guards: each line contains an integer, the number of awards the guard requires. Each guard requires at least 1, and at most l00000 awards. Guard i and i + 1 are neighbors, they cannot receive the same award. The first guard and the last guard are also neighbors.

The input is terminated by a block with n = 0.

Output

For each test case, you have to output a line containing a single integer, the minimum number x of award types that allows us to motivate the guards. That is, if we have x types of awards, then we can give as many awards to each guard as he requires, and we can do it in such a way that the same type of award is not given to neighboring guards. A guard can receive only one award from each type.

Sample Input

3
4
2
2
5
2
2
2
2
2
5
1
1
1
1
1
0
Sample Output

8
5
3

题意:有n个人围成一个环,n与1,n-1相邻。每个人都需要一定个数的礼物,相邻两个人的礼物不能相同,并且每种礼物的数目都是无限的,问能够满足条件的最少的礼物的总数。
分析:如果n为偶数,那么就是相邻两个数和的最大值,如果是奇数的话,只能枚举,将礼物分成两部分,左和右,偶数号的尽量选左面的,奇数的尽量选右边的,最后只需要判断l[n]是不是等于0即可(因为刚开始第1个是选取最左面的,如果n和1有重复的,那么l[n]肯定不是0)。(参考 入门经典);
代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
const int maxn = 1e5+5;
using namespace std;

int l[maxn], r[maxn], s[maxn], n;

bool test(int p){
    int x = s[1], y = p - x;
    l[1] = s[1], r[1] = 0;  //根据第一个将p分成两部分, 因为第一个是选取的左边的,所以下一个尽量选右边的,这样最后一个就是尽量选右边的,如果l[n] == 0,就说明满足要求(很巧妙,值得思考)
    for(int i = 2; i <= n; ++ i){
        if(i % 2 == 0){
            l[i] = min(x-l[i-1], s[i]);
            r[i] = s[i]-l[i];
        }
        else {
            r[i] = min(y-r[i-1], s[i]);
            l[i] = s[i]-r[i];
        }
    }
    return l[n] == 0;
}

int main(){
    while(scanf("%d", &n), n){
        for(int i = 1; i <= n; ++ i) scanf("%d", &s[i]);
        if(n == 1) {
            printf("%d\n", s[1]); continue;
        }
        s[n+1] = s[1];
        int L = 0;
        for(int i = 1; i <= n; ++ i) L = max(L, s[i]+s[i+1]);
        if(n % 2 == 1){
            int R = L*3;
            //for(int i = 1; i <= n; ++ i ) R = max(R, s[i]*3);
            int m;
            while(L < R){
                m = L+(R-L)/2;
                if(test(m)) R = m; else L = m+1;
            }
        }
        printf("%d\n", L);
    }
    return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值