数据结构实验之二叉树五:层序遍历(用c++stl 的queue完成的)

Problem Description
已知一个按先序输入的字符序列,如abd,eg,cf,(其中,表示空结点)。请建立二叉树并求二叉树的层次遍历序列。

Input
输入数据有多行,第一行是一个整数t (t<1000),代表有t行测试数据。每行是一个长度小于50个字符的字符串。
Output
输出二叉树的层次遍历序列。
Sample Input
2
abd,eg,cf,
xnl,i,u,
Sample Output
abcdefg
xnuli
Hint

Source
xam

AC代码

#include <bits/stdc++.h>

using namespace std;
struct node
{
    char data;
    struct node *lson;
    struct node *rson;
};
queue<node *>q;//**队列的类型是结构体指针**
char s[55];
int i;
struct node *creat(struct node *t)
{
    if(s[i]==',')
    {
        t=NULL;
        i++;
    }
    else
    {
        t=(struct node *)malloc(sizeof(struct node));
        t->data=s[i++];
        t->lson=creat(t->lson);
        t->rson=creat(t->rson);

    }
    return t;
}
void show(struct node *t)//队列的层次遍历
{
    if(t!=NULL)
    q.push(t);
    while(!q.empty())//循环输出
    {
        struct node *now=q.front();
        q.pop();
        cout<<now->data;
        if(now->lson!=NULL)
            q.push(now->lson);
        if(now->rson!=NULL)
            q.push(now->rson);
    }
}
int main()
{
    int n;
    scanf("%d",&n);
    struct node *t;
    while(n--)
    {
        i=0;
        scanf("%s",s);
        t=creat(t);
        show(t);
        printf("\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值