D-City(HDU4496)

D-City

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 2448    Accepted Submission(s): 862


Problem Description
Luxer is a really bad guy. He destroys everything he met. 
One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines in the input. 
Two points are in the same connected blocks if and only if they connect to each other directly or indirectly.
 

Input
First line of the input contains two integers N and M. 
Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line. 
Constraints: 
0 < N <= 10000 
0 < M <= 100000 
0 <= u, v < N. 
 

Output
Output M lines, the ith line is the answer after deleting the first i edges in the input.
 

Sample Input
  
  
5 10 0 1 1 2 1 3 1 4 0 2 2 3 0 4 0 3 3 4 2 4
 

Sample Output
  
  
1 1 1 2 2 2 2 3 4 5
Hint
The graph given in sample input is a complete graph, that each pair of vertex has an edge connecting them, so there's only 1 connected block at first. The first 3 lines of output are 1s because after deleting the first 3 edges of the graph, all vertexes still connected together. But after deleting the first 4 edges of the graph, vertex 1 will be disconnected with other vertex, and it became an independent connected block. Continue deleting edges the disconnected blocks increased and finally it will became the number of vertex, so the last output should always be N.
这个题的意思是给你一个联通块,然后就给你若干条边进行切断,没切断一条边输出其切断后的联通块。
 
  
这个题需要用到并查集的faA与faB是否相等来判断其是否会划分为联通块的个数,必须来进行倒着进行处理这些数据。
#include<stdio.h>
#include<string.h>
#include<stack>
using namespace std;
int n,m;
int father[10010];
int find(int x)
{
int a=x;
while(x!=father[x])
{
x=father[x];
}
while(a!=father[a])
{
int z=a;
a=father[a];
father[z]=x;
}
return x;
}
int Union(int a,int b)
{
int faA=find(a);
int faB=find(b);
if(faA!=faB)
{
father[faA]=faB;
return 1;
}
else
return 0;
}
int main()
{
int a[100010],b[100010];
while(scanf("%d%d",&n,&m)!=EOF)
{
stack<int > q;
if(n==0&&m==0)
break;
for(int i=0;i<=n;i++)
{
father[i]=i;
}

int flag;
q.push(n);
for(int i=0;i<m;i++)
{
scanf("%d%d",&a[i],&b[i]);
}
for(int i=m-1;i>0;i--)
{
int flag=Union(a[i],b[i]);
if(flag==1)
n--;
q.push(n);
}
while(!q.empty())
{
printf("%d\n",q.top());
q.pop();
}
}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值