HDU 4496 D-City(逆向)

D-City

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 3270    Accepted Submission(s): 1169


Problem Description
Luxer is a really bad guy. He destroys everything he met.
One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines in the input.
Two points are in the same connected blocks if and only if they connect to each other directly or indirectly.
 

Input
First line of the input contains two integers N and M.
Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line.
Constraints:
0 < N <= 10000
0 < M <= 100000
0 <= u, v < N.
 

Output
Output M lines, the ith line is the answer after deleting the first i edges in the input.
 

Sample Input
  
  
5 10 0 1 1 2 1 3 1 4 0 2 2 3 0 4 0 3 3 4 2 4
 

Sample Output
  
  
1 1 1 2 2 2 2 3 4 5
Hint
The graph given in sample input is a complete graph, that each pair of vertex has an edge connecting them, so there's only 1 connected block at first. The first 3 lines of output are 1s because after deleting the first 3 edges of the graph, all vertexes still connected together. But after deleting the first 4 edges of the graph, vertex 1 will be disconnected with other vertex, and it became an independent connected block.

Continue deleting edges the disconnected blocks increased and finally it will became the number of vertex, so the last output should always be N.

题意:给你一个n个点m条边的图,问当将前i条边删除后该图的连通分支数。

思路:删掉前i条边就相当于 给n个点加上后m-i条边。举个例子,比如一个图有5个点10条边,我要删除前8条边,求删除后的连通分支数,这问题就相当于我有5个点0条边,给这个图加上第9,10条边,求加上后的连通分支数。所以,我们可以逆向加边(逆向加i条边就相当于正向删m-i边),用并查集进行合并,如果当前要加边的两个点祖先不同(即其属于不同的连通分支),则加边后连通分支数应当减一。

#include<cstdio>
#include<cstring>
#include<vector>
#include<cmath>
#include<iostream>
#include<algorithm>
#include<queue>
#include<set>
#include<map>
using namespace std;

const int maxn = 10000 + 10;
const int INF = 1e9+10;
int n,m,pre[maxn];

int find(int x)
{
    return pre[x] == x ? x : pre[x] = find(pre[x]);
}

int a[10*maxn], b[10*maxn], ans[10*maxn];

int main()
{
    while(scanf("%d%d",&n,&m) == 2) {
        for (int i = 0; i < n; i++) pre[i] = i;
        for (int i = 0; i < m; i++) scanf("%d%d",a+i,b+i);
        int sum = n;
        ans[m] = n;
        for (int i = m-1; i >= 0; i--) {
            int x = find(a[i]), y = find(b[i]);
            if (x != y) {
                sum--;
                pre[x] = y;
            }
            ans[i] = sum;
        }
        for (int i = 1; i <= m; i++)
            printf("%d\n",ans[i]);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值