ZOJ 2095 Divisor Summation

刚开始做的时候不懂啊,怎么做怎么Time Limit Exceeded,那个心凉啊。

 

Time limit: 5 Seconds   Memory limit: 32768K   
Total Submit: 4504   Accepted Submit: 862   

Give a natural number n (1 <= n <= 500000), please tell the summation of all its proper divisors.

Definition: A proper divisor of a natural number is the divisor that is strictly less than the number.

e.g. number 20 has 5 proper divisors: 1, 2, 4, 5, 10, and the divisor summation is: 1 + 2 + 4 + 5 + 10 = 22.

 


Input

An integer stating the number of test cases, and that many lines follow each containing one integer between 1 and 500000.


Output

One integer each line: the divisor summation of the integer given respectively.


Sample Input

3
2
10
20


Sample Output

1
8
22


Author: Neal Zane


 

#include <stdio.h>
int main()
{
	int a[500001] = { 0 , 0 } ;
	int i , j ;
	for (i = 1 ;i <= 250000;i ++)
		for (j = 2 ;i*j <= 500000;j ++)
			a[i*j] += i;
	scanf ("%d",&i);
	while (i --)
	{
		scanf ("%d", &j);
		printf ("%d\n", a[j]);
	}
	return 0 ;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值