HDU 1113 Word Amalgamation【map+string+sort】

题目链接

Word Amalgamation

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6840 Accepted Submission(s): 3264

Problem Description

In millions of newspapers across the United States there is a word game called Jumble. The object of this game is to solve a riddle, but in order to find the letters that appear in the answer it is necessary to unscramble four words. Your task is to write a program that can unscramble words.

Input

The input contains four parts:
1.a dictionary, which consists of at least one and at most 100 words, one per line;
2.a line containing XXXXXX, which signals the end of the dictionary;
3.one or more scrambled `words’ that you must unscramble, each on a line by itself; and
4.another line containing XXXXXX, which signals the end of the file.
All words, including both dictionary words and scrambled words, consist only of lowercase English letters and will be at least one and at most six characters long. (Note that the sentinel XXXXXX contains uppercase X’s.) The dictionary is not necessarily in sorted order, but each word in the dictionary is unique.

Output

For each scrambled word in the input, output an alphabetical list of all dictionary words that can be formed by rearranging the letters in the scrambled word. Each word in this list must appear on a line by itself. If the list is empty (because no dictionary words can be formed), output the line ``NOT A VALID WORD" instead. In either case, output a line containing six asterisks to signal the end of the list.

Sample Input

tarp
given
score
refund
only
trap
work
earn
course
pepper
part
XXXXXX
resco
nfudre
aptr
sett
oresuc
XXXXXX

Sample Output

score
******
refund
******
part
tarp
trap
******
NOT A VALID WORD
******
course
******
思路

熟练使用stl,用map存储字符串,用sort将不同排序的字符串化为同一顺序

完整代码:
#include <iostream>
#include <string>
#include <algorithm>
#include <map>
#include <fstream>
using namespace std;

//ifstream fi("input.txt",ios::in);

int main()
{
    string words[110];
    string res[100];
    string str;
    map<string,int> mp;
    int i=0;
    int sum=0;
    int len=0;
    //输入单词
    while(/*fi*/cin>>str){
        if(str=="XXXXXX"){
            len=i;//单词总数
            break;
        }
        words[++i]=str;
        sort(str.begin(),str.end());//排序,这样就能把正常与混乱的单词化为同一形态
        mp[str]++;//记录此种情况单词的数量
    }
    //输入受扰乱单词
    while(/*fi*/cin>>str){
        if(str=="XXXXXX")
            break;
        sort(str.begin(),str.end());//同上
        if(mp[str]!=0){//如果此种形态单词数量非零
            sum=0;
            i=0;
            for(int k=1;k<=len;k++){//遍历所有单词(正常状态)
                string str_tmp;//中间变量
                str_tmp=words[k];
                sort(str_tmp.begin(),str_tmp.end());
                if(str==str_tmp){//如果同一形态
                    res[i++]=words[k];//存入结果中
                    sum++;
                    if(sum==mp[str]){//如果总数达到上限
                        break;
                    }
                }
            }
            sort(res,res+mp[str]);//按字典序排列
            for(int k=0;k<mp[str];k++)
                cout<<res[k]<<endl;
            cout<<"******"<<endl;
        }
        else
            cout<<"NOT A VALID WORD"<<endl<<"******"<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值