HDU 1024 Max Sum Plus Plus【#1024程序员节#+动态规划】

这是一个关于解决最大子序列和问题的程序代码实现,使用了动态规划的方法。题目要求在给定的一串整数中,找到m对子序列,使得这m对子序列的和最大。代码通过计算每个位置的前缀和,并使用动态规划找到最优解,最后输出最大的总和。
摘要由CSDN通过智能技术生成

HDU 1024 Max Sum Plus Plus

Max Sum Plus Plus

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 51455 Accepted Submission(s): 18818

Problem Description

Now I think you have got an AC in Ignatius.L’s “Max Sum” problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S1, S2, S3, S4 … Sx, … Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define a function sum(i, j) = Si + … + Sj (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + … + sum(im, jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).

But I`m lazy, I don’t want to write a special-judge module, so you don’t have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. _

Input

Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 … Sn.
Process to the end of file.

Output

Output the maximal summation described above in one line.

Sample Input

1 3 1 2 3
2 6 -1 4 -2 3 -2 3

Sample Output

6
8

Hint
Huge input, scanf and dynamic programming is recommended.

完整代码

#include <iostream>
#include<cstdio>
#include<memory.h>
using namespace std;
const int maxn=1000005;
const int maxm=100;
const int inf=0x7ffffff;
int num[maxn];
int d[maxn];
int pre[maxn];

int main()
{
    //freopen("in.txt","r",stdin);
    int m,n,tmp;
    while(cin>>m>>n){
        int tmp;
        for(int i=1;i<=n;++i){
            cin>>num[i];
        }
        //dp[i][j],第j个人放在第i组时的最大值(1<=i<=j<=n,1<=i<=m)
        memset(d,0,sizeof(d));
        memset(pre,0,sizeof(pre));
        for(int i=1;i<=m;++i){
            tmp=-inf;
            for(int j=i;j<=n;++j){
                d[j]=max(d[j-1],pre[j-1])+num[j];
                pre[j-1]=tmp;
                tmp=max(tmp,d[j]);
            }
        }
        cout<<tmp<<endl;
    }
 
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值