POJ 1248 Safecracker(我的水题之路——五重循环暴力- -!)

Safecracker
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 1267 Accepted: 790

Description

"The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World War II. Fortunately old Brumbaugh from research knew Klein's secrets and wrote them down before he died. A Klein safe has two distinguishing features: a combination lock that uses letters instead of numbers, and an engraved quotation on the door. A Klein quotation always contains between five and twelve distinct uppercase letters, usually at the beginning of sentences, and mentions one or more numbers. Five of the uppercase letters form the combination that opens the safe. By combining the digits from all the numbers in the appropriate way you get a numeric target. (The details of constructing the target number are classified.) To find the combination you must select five letters v, w, x, y, and z that satisfy the following equation, where each letter is replaced by its ordinal position in the alphabet (A=1, B=2, ..., Z=26). The combination is then vwxyz. If there is more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a dictionary." 

v - w 2 + x 3 - y 4 + z 5 = target 

"For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 9 2 + 5 3 - 3 4 + 2 5 = 1. There are actually several solutions in this case, and the combination turns out to be LKEBA. Klein thought it was safe to encode the combination within the engraving, because it could take months of effort to try all the possibilities even if you knew the secret. But of course computers didn't exist then." 


"Develop a program to find Klein combinations in preparation for field deployment. Use standard test methodology as per departmental regulations. 

Input

Input consists of one or more lines containing a positive integer target less than twelve million, a space, then at least five and at most twelve distinct uppercase letters. The last line will contain a target of zero and the letters END; this signals the end of the input.

Output

For each line output the unique Klein combination, or 'no solution' if there is no correct combination. Use the exact format shown below." 

Sample Input

1 ABCDEFGHIJKL
11700519 ZAYEXIWOVU
3072997 SOUGHT
1234567 THEQUICKFROG
0 END

Sample Output

LKEBA
YOXUZ
GHOST
no solution

Source


题意是说有一种密码规则,将用五个字母表示一个数字,一个字符串VWXYZ,表示字母target v - w 2  + x 3  - y 4  + z 5  = target 
V、W、X、Y、Z分别表是五个字符,则字符的值为其在字母表中的编号(A=1,B=2,C=3...)。
现在将给你一个目标数字,以及一个5到12位的字符串,用这5到12个字符中的其中5个字符组成字符串VWXYZ,表示出这个数字,求其字符顺序最大的结果。

解这道题用了五重暴力循环,本以为要TLE的,不过幸好1AC了。

注意点:
1)这个目标字符串中各个字符并不相同
2)五重循环需要一次性跳出,需要设置一个标记变量用于跳出循环。

代码:
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>

using namespace std;

char keys[20];
int N;
int number[30];

void initsolve(){
    for (int i = 1; i <= 30; i++){
        number[i - 1] = i;
    }
}

int getresult(char key[]){
    int result = 0, tmp;
    int i,j;

    for (i = 1; i <= 5; i++){
        for (j = i, tmp = 1; j > 0; j-- ){
            tmp *= number[key[i - 1] - 'A'];
        }
        if (i % 2 == 1){
            result += tmp;
        }
        else{
            result -= tmp;
        }
    }
 //   printf("result:%d\n", result);
    return result;
}

int judge(char key[], char ch, int at){

}

int main(void){
    char key[10] = "YOXUZ";
    int len;
    int i, j, k, l, m;
    int flag;

    initsolve();
    //printf("%d\n", getresult(key));
    while (scanf("%d %s", &N, keys), N != 0 && strcmp(keys, "END") != 0){
        flag = 0;
        sort(keys, keys + (len = strlen(keys)));
      //  printf("%s\n", keys);
        for (i = len - 1; i >= 0 && flag == 0; i--){
            key[0] = keys[i];
            for (j = len - 1; j >= 0 && flag == 0; j --){
                if (j != i){
                    key[1] = keys[j];
                    for (k = len - 1; k >= 0 && flag == 0; k--){
                        if (k != i && k != j){
                            key[2] = keys[k];
                            for (l = len - 1; l >= 0 && flag == 0; l --){
                                if (l != k && l != j && l != i){
                                    key[3] = keys[l];
                                    for (m = len - 1; m >= 0 && flag == 0; m --){
                                        if (m != l && m != k && m != j && m != i){
                                            key[4] = keys[m];
                                            key[5] = '\0';
                                            if (getresult(key) == N){
                                                flag = 1;
                                            }
                                        }
                                    }
                                }
                            }
                        }
                    }
                }
            }
        }
        if (flag){
            printf("%s\n", key);
        }
        else{
            printf("no solution\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值